Haproxy setup with Bullseye

What is the problem?

I'm setting up Octoprint on a Pi4 with Bullseye installed. OP setup went just fine and it works well. I cannot get Haproxy to run properly. I can do the basic install, and it runs, but does not give me the proper results (that is, access to OP via only the IP address without the ":5000." As soon as I update the .cfg file, I get an error when starting Haproxy. I tried the things suggested in the Reverse Proxy thread to no avail. Anyone run into this before?

What did you already try to solve it?

WRITE HERE

Have you tried running in safe mode?

WRITE HERE

Did running in safe mode solve the problem?

WRITE HERE

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

WRITE HERE

The error may not make sense to you, but it has the only information that can help in solving your problem. Error-messages are not there for decoration only; they try to tell you what is going wrong. Without knowing the error, there is no way anyone can help you.

3 Likes

Fixed the problem. It was a matter of replacing one of the "reqrep" keyword in the backend webcam section and eliminating the line from the backend octoprint section. Now working like a champ.