Have to connect to the printer twice on serial

What is the problem?

I just updated my printer (CR-10S with SKR 1.3 board) to Marlin 2.0.9.2 from 2.0.6.1 For some reason, it now requires that I hit the "CONNECT" button twice before it connects to the printer, as it errors out the first time. Once I do this, it connects successfully and everything works normally.

I'm using Tasmota-MQTT addon to automatically connect to the printer after 8 seconds of turning the printer on. This has worked consistently in the past but no longer does (it errors out the first time).

I have enabled Meatpack support in the firmware and installed the Meatpack addon. However, disabling the add-on did not solve the issue. Additionally, I was also seeing this BEFORE enabling Meatpack (I recompiled Marlin with it enabled), so I'm thinking that it isn't related.

This is more of an annoyance than anything, as Octoprint works just fine once it is connected. Meatpack also works and is showing the compression ration and such.

Systeminfo attached.

What did you already try to solve it?

Disabled the Meatpack addon.

Have you tried running in safe mode?

No.

Did running in safe mode solve the problem?

N/A

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20211122110414.zip (105.1 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.7.2, Python 3.8.6 running on vanilla Raspbian (not OctoPi) on Raspberry 4. Marlin 2.0.9.2. SKR 1.3 board.