Have to reload Creality Firmware after each print

What is the problem?

Since loading OctoPrint 1.7 and 1.7.1 after each printing I have to reload the Creality CR10S V2 Pro Firmware. If I do not reload the printer extruder stays about 30mm above bed and tries to print the model.

What did you already try to solve it?

Looked on line for possible solutions and did find any

Have you tried running in safe mode?

Yes, same result

Did running in safe mode solve the problem?

No, same result

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20211102162050.zip (108.7 KB)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Does your printer home at the start of the print?

Yes, but about 30 mm above the bed. Turned off Octopi and have reloaded firmware and it is printing small model just fine. Will let you know if it will print without issue just using printer. Should have answer in 15-20 minutes.

When you say "reloading the firmware", do you mean actually reflashing it, or just restarting the printer?

Refreshing it to printer. I used Creality Cura to do this.

Should have said reflashing not refreshing. Spellchecker struck again.
Just finished small model print using SD card and print was fine. Have restarted from SD card and it is printing correctly. Will stop this print cycle and try restarts with Octopi.local.

Have you tried just restarting the printer as well? Having to reflash sounds like something is seriously wrong on the firmware side frankly, normally a restart should clear any weird state.

1 Like

Have restarted printer a number of times yesterday and today. I just started the same model thru Octopi.local and it is running fine. Installed 1.7.2 will see what happens at conclusion of print and new start.

From the looks of your logs at least, OctoPrint is telling your printer to move to sensible coordinates close to the bed on print start, not anything weird. I also see a homing command there that the firmware should execute in X, Y and Z. So whatever this is, it's probably a weird state the firmware gets in. The question is why, there's nothing I could think of that could cause something like this.

Turned off printer and Raspberry Pi. Waited a few minutes and restarted Pi and shortly thereafter the printer. Logged into Octopi.local. Reloaded model, preheated and started print. Printer is functioning correctly. Only thing I am wondering about is glitch in slicer. Going to stick with Creality Cura 4.8.2 for time being and see how things progresses. Was using Cura 4.11
Thank you for bearing with me. I am old guy that loves 3D creation and printing and appreciate Octopi because I am not up and down stairs all day to check on printing status

Looks like recent Prusa and Cura Slicer upgrades are the issue. Will to do more testing to verify and that will take several days. Creality Slicer works.

maybe wrong profile in both slicer ?
So that weird GCode is sent to the printer, that mess up the printers eeprom ?
Sounds like that weird Z-coordinates are sent to the printer and the alligned z-position (Z-0)is set to something like 30mm or whatever ..
Try to delete all startup g-code in your slicer profile maybe ?



I had a similar issue with my cr6se but i was setting up and using Prusa slicer. Cant remember if it was ONLY after a failed print or after all the prints.
I Know it definitely did this after a failed print...would not home Z and start next print mid air.
Powering the printer down and back on fixed for the moment but did not solve the issue.
I think i had to fix a problem with my end gcode setup in my slicer.
Sorry it was so long ago i cant be more helpful

NOTE: i was using the cr6se community firmware, not original. but i have had less problem with the community than the official so i don't think that had anything to do with it

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.