πŸ‡ΊπŸ‡¦ We stand with Ukraine! πŸ‡ΊπŸ‡¦

Having SO much trouble SSHing into octopi.local

What is the problem?

Hello, So I've run into a dead end trying to communicate with my RPI 4 to give it some needed commands I believe by ssh. For the record, I've never gotten this to work and I was never able to get into the rasbian os or octopi, from the get go when I initially setup my RPI4. I just went straight to the octoprint wizard and got the rpi up and running and off to printing. The RPI is currently plugged into the printer and wirelessly connected to my home network. I can see the ip address on my router page and I use this ip address in my browser (on windows 10) to use octoprint. This has been working flawless for months. Now, I have some settings I would like to change (or add) for a webcam and cannot connect via ssh ing in command prompt. I believe not setting up my RPI from the get go, by changing it's default username and password is why I'm having troubles now, or I feel that was a needed step I skipped. In command prompt when I type in ssh pi@octopi.local I get "no such host is known". If I type ssh (ip address) of the rpi it asks for password. I don't know what password it could want. I've tried all of them, including "raspberry" permission denied. I'm NOT good at this lingo, so please be kind :).

What did you already try to solve it?

I have reinstalled the octoprint instance numerous times and have never gotten it to ask me for the default "username and password" ever using Command prompt. I can see the RPI's ip address on my router and am able to log into octoprint via the ip address in my browser.
I do have Bonjour installed in my computer

Have you tried running in safe mode?

I have not tried running it in safe mode. My computer? Or Octoprint? Not sure this applies to my issue?

Did running in safe mode solve the problem?

WRITE HERE

Complete Logs

ssh: could not resolve hostname octopi.local: No such hose is known.
password: permission denied. please try again.
octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

WRITE HERE

Additional information about your setup

I have latest octoprint and octopi. Printers are Creality. Using Chrome on Windows 10
Have Putty installed and Bonjour networking
OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

WRITE HERE

What language/layout is your keyboard? The default is definitely raspberry, if you have reflashed this you exclude any chances of having changed this.

I know on some keyboards, some of the keys are switched around - the Pi defaults to QWERTY, UK layouts (afaik, the 'uk' bit may not be the correct term).

1 Like

Good ole ordinary English Language? At least that's how I see it typed out, haha. Yes, I'm so confused with this dilemma. I currently have one RPI 4 on right now operating my printer as we speak. If I open command prompt, it says "c:\Users\wabas>. If I try to type in, ssh "the ip of said RPI" . It then prompts, "wabas@ip address's" password: . And no matter what password I type in (which it should be "raspberry") it says "permission denied, please try again."

Try ssh pi@<ip> - it looks like it is interpreting the user of your PC as the one for the Pi, you can override by saying 'I want pi'.

Holy heck, that worked!! I can't believe it! So, thank you first off. My next question, since I have yet to configure this part of the sequence on any of my pi's. If I go in here and set this up, will I have to reconfigure this pi in the current printer profile it is operating on? I guess I'll find out, what's another task to have to redo.
Thank you so much, it's those little things that get me so flustered. :wink: