Help a Newbie Old Man out......Pi 4 update and now cant log in

did an update on my pi 4 and had the Pi boot to a desktop and when it booted up it came up with a debian login screen and I cant log in......ARRGGGGHHH

I have tried both the password that I changed it to as well as the default : pi / raspberry

I am really new to the Raspberry Pi world and to 3D printing. Old Man new hobby kind of thing..... Im trying to learn but Im just used to a desktop environment so Someone please help educate the elderly......:joy:

Hi :slight_smile:
Where are you from? Maybe the wrong keymap is loaded and you're entering the wrong password without noticing.
For example on the german keyboard layout the z and y keys are switched compared to the us layout.
So you need to enter raspberrz in that case.


Additionally, if your password includes a double quote, you have a U.S.-based keyboard as combined with the default UK-based keyboard driver, then it won't type what you expect.

Try using ssh pi@octopi.local from another workstation; it will work with your workstation's keyboard (and a double quote would be a double quote in this case). If that works (using the Raspbian password, not to be confused with the OctoPrint password), then you can update your password by running passwd.


If you don't know anything about ssh and console based stuff this video could help you with the basics.

1 Like

Im in Virginia. I was able to log into it fine in command line, but after I did an upgrade I decided to I wanted to try using a desktop view. So I went into the Config and made it boot to desktop view and it came up asking for a login and password and underneath it says Debian….. Im using Octoprint for the OS that I flashed from the site…….

I tried changing my password in Octoprint but that didn’t work. I could log into it from the command line just fine. Once I did the upgrade and went into the config file and made it boot to a desktop it hasn’t worked. It actually says Debian under the login area. Im using Octoprint as my OS that I flashed from the site. As I said im really new to this. But now I cant get off of the login screen. Was hoping it was like DOS and you could force it to go back during the boot process by hitting a certain key…….

Man, I appreciate it. that got me in to be able to reboot it to a command line. still not sure why the desktop mode went to Debian though. Or would it acknowledge my user name and password. Thanks for the lesson. Hope I can repay the favor someday......

@jfulwider Welcome to the club. As a fellow "old man" I can empathise. I'll offer a couple of tidbits...

I believe the operating system you are using is called OctoPi. It is Raspbian Lite with OctoPrint and other applications pre-installed. Raspbian is a derivative of Debian. The OctoPrint application can be installed on other OSes so that's why we refer to the OS as OctoPi and the application as OctoPrint.

The RPi 4 is brand new and OS support is still a work in progress. I would suggest that you spend some time learning to use the command line (via SSH) as most OctoPrint users do not install a desktop on OctoPi. Using the desktop while there is an active print job can result in artifacts or failure of the print.

As the OS support matures, installing the desktop on an RPi 4 may make more sense but at this point in time, your lack of success could be as much a software problem as operator error.

1 Like

That makes perfect sense. I appreciate the lesson. I'm hoping to become proficient at using the Octopi as well as Raspberry Pi. I absolutely love it so far just have to stop getting ahead of my skill set.... Thanks again.

What 3D printer do you have? What kind of desktop are you modeling / slicing on? If it is Windows, then another useful application is WinSCP.

I have a Ender 5, and use my Surface Pro to use Octoprint and slice with Cura.

If all else fails you could use the password reset procedure

1 Like