Help needed with issue about GPIO-Pins and 7" Raspberry display

I'm currently facing the issue, that I can't seem to get both the touchscreen and the IO-Pins from my RPI 4 to run with eachother.

I'm trying to build myself an enclosure for my I3 MK3s that also has multiple relais built into it for controlling multiple functions. The reason why I decided to use relais-boards instead of just using simple switches was that I wanted to be able to control them using an add-on for octoprint called enclosure-plugin. In addition to this I planned on using a raspberry 7" display combined with a touch-interface add-on to simplify using octoprint without having to turn on my PC every time.

Now to my problem:

I first started work on getting the relais-boards, buttons, sensors etc. wired up with each other and getting the enclosure plugin set up which, although it took much longer than expected, seemed to work quite well, until now, about 9 months after having started the whole project, I tried to get the touchscreen to run. I hooked up everything the way it said in the instructions, but no matter what I tried I wouldn't get any reaction to any touch inputs. This seemed especially weird to me because A) I used the original raspberry screen that connects with the ribbon cable to avoid having to deal with driver issues and B) the actual display worked just fine the entire time showing me the terminal and later when I noticed the issue the desktop. In addition to this I could also remember using the display in combination with octodash before starting the wiring, without issues (I'm actually not sure if this was with the same raspberry or not since I switched from a used 3 from ebay to a 4 once I could finally manage to get one and I'm not sure if this was before or after trying out octodash)

I did a bit of research on this, figuring that for whatever reason the firmware didn't work the way it was supposed to, and found a german post on how to manually start a firmware update using the "sudo rpi-update" command. This initially seemed to work, making the display capable of registering my inputs again, until I noticed that suddenly the enclosure plugin wouldn't respond to any inputs anymore. I tried resetting the enclosure plugin, using an antirely different plugin, testing all the relais boards and their connections and a few other things, all without success until I reinstalled octoprint from scratch. Unfortunately this only was a partial fix though, since although the GPIO-pins worked again I was back at the beginning with the touch-issue which, again, I could only fix by updating the firmware which, again, rendered the GPIO-pins useless until I reinstalled Octoprint.

Does anyone have an idea on how I can possibly get this to work the way its supposed to or atleast on what this is all about? I kind of have the feeling that it has something to do with the RPI4 using the ribbon cable instead of GPIO-pins to tranfer touch-inputs, but on the other hand this is the original display produced by raspberry themselves so it should actually be more than obvious to them that by making the raspberry not have any usable GPIO-pins they kind of defeat the whole purpose of it being a raspberry in the first place. In addition to this I could'nt seem to find any other posts about this issue, but I'm not sure if I possibly searched for the wrong thing or something like that....


I'm facing the problem that I can't figure out a way to get the "touch"-part from my raspberry 7" Touch display to work. The only thing I could do to get some kind of change to happen was to run the "sudo rpi-update" command, which also only was a partial fix since this made the touch work but rendered the GPIO-pins useless until I reinstalled everything from scratch putting me back to where I was at the beginning.

When you opened this topic, there was a template which you deleted. We can provide you with much better support if you make your best effort to provide us with the information the template asks for.

I believe the issue(s) you are facing are operating system related and you have provided no information about the operating system you have installed. You mention reinstalling OctoPrint but there are no details about how you accomplished that. I finally figured out that "relais" is the French word for the English "relay".

I suggest that you fill out the template as best you can (open another new topic if you need a copy). The blue text strings in the template are links which will provide additional instructions if you need them. Please also provide as much information as you can about your hardware including part numbers and/or model numbers. Also include version numbers of any additional software. can provide some insight into the Raspberry Pi updating process.

1 Like