Help rotating touchscreen on new install

What is the problem?

After updating to OctoPrint 1.8.0, I needed to rotate my touchscreen 180deg, but now when I touch the screen, the mouse pointer is opposite of where I touch the screen. I've looked up how to remedy this, but, according to this fix, I need to be in the pi@raspberry directory, or whatever it's called. However, after updating to 1.8.0, I selected the option to open in Octopi, ie, pi@octopi. How can I switch to pi@raspberrypi in order to make the changes to fix the touchscreen problem? Otherwise, does anyone know how I can make the needed changes inside of pi@octopi?

What did you already try to solve it?

used the cd command but it said file not found, then I screamed, cursed, and then turn it off...

Have you tried running in safe mode?

nope, but I did try unsafe mode - I like to live dangerously...

Did running in safe mode solve the problem?

nope, and adding water didn't help, either...

Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/98.0.4758.102 Safari/537.36
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1400.0
env.hardware.ram: 914010112
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: True
octoprint.safe_mode: False
octoprint.version: 1.7.3
systeminfo.generator: zipapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.8.0, CR10S, Marlin 2.something, Google chromium, whatever raspberry pi runs on - some type of Linux, I'ma thinkin'...

pi@octopi and pi@raspberry are both the same thing for what you are looking for. pi is obviously the username, while octopi or raspberry is the hostname of the Pi. The current location (that would change when you use cd is the 3rd segment, usually coloured blue, just after:

They should work exactly the same, but I can check if you have a link to the guide you are trying to follow.

This is what I found on the internet that seemed to be the easiest at fixing the issue, but I'm not 100% sure. I don't recall having to do this when I initially set this up several years ago. I tried the command "cd /usr/share/X11/xorg.conf.d/" the website gives to enter the fix but it gave a "file not found" or "bad command", one of the two, but it didn't open up the configuration file as it said it would.

Here's the link: Rotate Raspberry Pi Display and Touchscreen : 4 Steps - Instructables


Well that path doesn't seem to exist for me either, so I guess that's something

There was this post that is doing a similar thing, but with a different file path

Inverting an HDMI display on the Raspberry Pi 4B - Get Help / Guides - OctoPrint Community Forum

I don't know if it's relevant for your touchscreen, as this is for one with a HDMI/USB combination. What kind of screen do you have?

The screen I have connects with a ribbon cable for video and two jumper cables for power. The model number is JGY2217 TOUCHPL000206, but when I googled it I didn't find any other information on it. It is a 7" touch screen but I have no idea where I bought it from.

Try adding lcd_rotate=2 to the /boot/config.txt file, without the display_rotate stuff. I have an official RPi 7" screen that connects with the ribbon cable, and that works for that display.

I initially added display_lcd_rotate=2 to rotate the screen. I believe this is what caused the problem - the screen rotated but the touch part didn't . So you think if I just add lcd_rotate=2 that would solve the touch part without returning the screen back?

It works for me, so I hope it does work for you as well!

Yessir, that worked perfectly. My screen is now normal - I'm not, but that doesn't matter. Thank you, very much!!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.