Help with a CETUS MKII (MK 2)


#1

I can not get Octopi \ Octoprint to see my Cetus MKII (I am new to 3d printing too btw)

I have tried different cables, reloaded the entire OctoPi software on a newer raspberry pi 3+
Everything is wired and verified plugged in.
I have tried starting the printer first, second, resetting, and even adding a plugin to auto refresh the devices (not currently installed since reload of Octoprint)

I see the device listed when I do a dmesg

[ 2.091425] usb 1-1.3: new full-speed USB device number 4 using dwc_otg
[ 2.224056] usb 1-1.3: New USB device found, idVendor=4745, idProduct=277f
[ 2.226894] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2.229754] usb 1-1.3: Product: Cetus S7(NL)
[ 2.232567] usb 1-1.3: Manufacturer: Tiertime
[ 2.235282] usb 1-1.3: SerialNumber: 70174081

I see it as more of a generic device when I do a lsusb

Bus 001 Device 004: ID 4745:277f <--- Pretty sure this is it??
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Under my Serial log I get

Changing monitoring state from "Offline" to "Detecting serial port"
Serial port list: [] <-- this concerns me
Changing monitoring state from "Detecting serial port" to "Error: Failed to autodetect serial port, please set it manually."
Failed to autodetect serial port, please set it manually.

Octoprint Version
Installed: 1.3.9

Anyone running this printer or can point me in the right direction?


#3

It may be time to take the software's advice and to set the serial port and baudrate manually.

Before plugging the printer in via serial cable, do an ls -l /dev on the Raspberry. Plug the serial in and repeat. A new device will show up in this directory and that's the port you'll need to use.


Read all of this.

Same problem I am having with S3D doesn’t connect to Cetus MkII extended. S3D says it’s a communication error because Cetus uses a proprietary code sequence in their transmission to the printer. They say they have a MkII and use it in their office. Their only solution was to create the G-code in S3D and print it using the Cetus software (which I find to be excellent — I take stl files from sketchup straight to the Cetus software and print) Hope this issue gets resolved.

Just a bit of advice to anyone who’s not very savvy: Simplify3D will NOT work right off the box with the Cetus3D MKII. It WON’T connect to the printer via USB or wireless. The Cetus3D is not “supported” in the general sense of the term. It’s not “load STL > slice > print”. Be very aware of that before you shell out $150 for S3D. The profile at the beginning of this thread will NOT work on every case. I’ve purchased S3D, followed every single one the instructions here, spoken to the S3D support, and it simply won’t work. Loading the gcode will fail. When the gcode loads, the stepper motors will bang against the endstops until you kill the print, even when you remove all the G28 codes. If you’re knowledgeable enough to make it work, by all means, get S3D. It’s a fantastic piece of software. But, if you’re a newbie like me, skip S3D. Stick with the Cetus slicer and save some money and heartbreak.


#4

I have also reached out to CETUS to see what they say. I will read through the link and see what I can find for sure. IF I can get it to work i will post up a how to... I REALLY want to dedicate a PI to this thing vs a Laptop, but hey what ever it takes I guess...