Help with CR-10 Max Axes settings

Hi there,

I'm totally new to 3d printing, but I'm trying to grasp everything.

What is the problem?
I'm trying to figure out the values to insert in the axes for the printer, but I'm unsure which values it is.

What did you already try to solve it?
I've run the command to the printer "M503" to get the output needed, but I'm unsure what values here should be entered into octoprint axes settings. From what I understand it's the valus from either M203 or M201, but how should they be added, is there a conversion for the units or something? Thanks!

Send: M503
Recv: echo: G21 ; Units in mm
Recv: echo: M149 C ; Units in Celsius
Recv: echo:Filament settings: Disabled
Recv: echo: M200 D1.75
Recv: echo: M200 D0
Recv: echo:Steps per unit:
Recv: echo: M92 X80.00 Y80.00 Z400.00 E140.00
Recv: echo:Maximum feedrates (units/s):
Recv: echo: M203 X500.00 Y500.00 Z10.00 E50.00
Recv: echo:Maximum Acceleration (units/s2):
Recv: echo: M201 X500 Y500 Z100 E5000
Recv: echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
Recv: echo: M204 P500.00 R1000.00 T500.00
Recv: echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
Recv: echo: M205 S0.00 T0.00 B20000 X8.00 Y8.00 Z0.40 E5.00
Recv: echo:Home offset:
Recv: echo: M206 X0.00 Y0.00 Z0.00
Recv: echo:Auto Bed Leveling:
Recv: echo: M420 S0 Z2.00
Recv: echo:PID settings:
Recv: echo: M301 P30.86 I3.10 D75.84
Recv: echo:Z-Probe Offset (mm):
Recv: echo: M851 Z-1.40
Recv: ok

Additional information about your setup
OctoPrint: 1.4.0
OctoPi: Version 0.17.0, running on Raspberry Pi 4 Model B Rev 1.1
Printer: Creality CR-10 Max (default firmware 1.70B)

Any help is appreciated, thanks :slight_smile:

According to the M203 documentation, these are units per second and this command sets the maximums allowed. The printer profile want units per minute so multiply the M203 values by 60.

The note on the printer profile page says This information is used for manual control via the "Control" tab. so as long as the values here don't exceed the maximums (which they don't), you can leave them alone.