Help with Cura Engine Legacy

I tried to start configure slicing with octoprint, but I can’t find out what is „path to cura Engine Legacy“.

Cura 15.04.3 ini file for Ender 3 is ready.

Which octopi version did you flash to your pi? The reason I ask is because based on the release notes it appears that it was removed from the image in 0.18. This means you would have to download and compile it manually.

These would be the command necessary for downloading and compiling based on the original octopi scripts that were probably the last ones that were bundled. It was the newest compatible version with the single file ini config.

sudo apt -y install gcc-4.9 g++-4.9
wget -O
pushd CuraEngine-15.04.6
make -j3 CXX=g++-4.9 VERSION=15.04.6
sudo cp build/CuraEngine /usr/local/bin/cura_engine
rm -r CuraEngine-15.04.6

then the path in the settings would be /usr/local/bin/cura_engine

I think installed is 1.5.3 ?

That's the OctoPrint version, not the octopi version. It shows up in the bottom left corner of the main OctoPrint page.

Yes, it’s OctoPi 0.18.0

Yeah, my commands above would work for you then, mostly the same as what's documented on the plugin's readme.

1 Like

Fine! But I don’t understand. What I have to do now exactly? When I copy and paste /usr/local/bin/cura_engine in that field it tells me wrong path. I think I missed something from tutorials in cause of translation. I’m an old german, not one of these Korean hacker-kids and I just started with that nerdy stuff here.:wink:

You need to download the source files for Cura 15.04.6, install the compiler(s) necessary, and build the executable image from the source files. @jneilliii provided the set of commands necessary in his post (the third one of this thread).

I would recommend NOT doing this. This version of Cura is ancient and if you slice files on the Raspberry Pi while it is actively printing, your printed object could have artifacts or blemishes. You will also have to 1) manually create / edit your .ini file(s) if you want to change any of the slicer settings, or 2) Install the full Cura 15.04.6 on a desktop (or laptop) computer so you can use it to manipulate .ini files.

Cura, slic3r, and just about all the other slicers available today have a graphical user interface and many of them have the ability to output the gcode directly to OctoPrint.

In the long run, you will be much happier with a full featured slicer running on a desktop or laptop and letting your Raspberry Pi with OctoPrint do what it does best, control and monitor the printer.

1 Like

Sometime this year there will be some changes incorporated to the CuraEngine that will allow for being able to utilize modern day versions easier hopefully. I was able to get the latest Arachne beta version compiled and running from command line, so the age of the slicer is not the issue for integration, but the way they store their settings in the new versions with dependency/inheritance makes it difficult to get your settings out of Cura to utilize in a plugin. It really needs to be a clean single file json similar to the old ini system.

Ok. My goal is to find a way for easy printing just using my IPad. I invent on Tinker with my pad, slicers for iPad are not available. I tried AstroBox for an easy way, but it didn’t work with my Ender 3 Pro so I use astroprint in octoprint. But it’s still a long way from a thought to a printed item. I try to find a quick an easy way.
The situation remembers the time of first CompactDisk-Burners, win95- 2x burning- stop breathing- look for weather forecast - bluescreen...

There are web-based slicers available which should work from your iPad. Try Kiri:Moto or Slicecrafter.

1 Like

There's even a kiri moto plugin to embed it within the octoprint interface.

These are really good tips. I’ll check it out, but first I will go fishing for a few days. :relaxed:
I’ll tell you further more after fishing...

And to add another option if you want to work off the internet for slicing / printing is to install the graphical interface on the pi and then install a slicer like ideamaker or cura on it.
You can use remote-acess on the pi with for example VNCviewer (realvnc on your tablet or from a computer) to control it and slice. A Pi-4 or even a 3B can do this job but you might want to do this when your printer is not printing to prevent it from hickups because of high load.
I use this and it works quite well though slicing takes a long time compared to a (bit modern) pc or laptop.
Of course you can also use an old PC or laptop for Octoprint or for slicing.

Just extra options. Hope you catched many fish!

Slicecrafter don’t work with iOS. But Kiri Moto looks good. I’ll try it.
I tried the vnc-thing before, it’s kind of messy stuff, I don’t like it.
Anyhow thank you all very much!