Help with Octoprint Consistently Failing Prints

What is the problem?

Octoprint is consistently stopping in the middle of a print, leaving the print head where it is, both the hot end and bed are left on and kept at set temp. There are no errors reported.

What did you already try to solve it?

*Tried 5 different power sources. (Two CanaKit certified.)
*3 different USB cables.
*4 different SD cards
*Re-flashed 10+ times
*Taped 5v pin on USB cable
*Replaced original Raspberry Pi 3B+ with Raspberry Pi Zero 2 W
*Disconnected web cam
*Ran Pi out of it's enclosure, bare-board, away from printer
*Confirmed consistent voltage with a voltmeter at the board
*Not running plugins
*Ran Pi from dedicated outlet
*Confirmed that all outlets are wired properly using outlet tester and voltmeter
*Issue does not occur when printing from a USB stick in the printer

Have you tried running in safe mode?

No, didn't know there is a safe mode.

Systeminfo Bundle

Additional information about your setup

*Octoprint 1.7.3
*Octopi Version 0.18.0, running on Raspberry Pi Zero 2 W Rev 1.0
*Artillery Sidewinder X1 V4 printer w/aluminum bed & Hemera Extruder
*Windows 10 OS
*MS Edge Browser

Here is a link to a log during which it occurred:

This only recently started happening. I've owned this printer for about 2 years and only in the past month has it started. About 60% of all prints fail. Thank you in advance for any help.

Already took in consideration to flash a new printer firmware?

BTW: you can upload the systeminfo bundle zip file here. It's a bit more convenient

I'm running a bunch of test prints today and it's failing almost every one, so I'm able to perform a little more reliable diagnosis. What I think I'm starting to realize is that the Pi is re-starting for some reason. Because if I try to refresh the page right after it does it, it does all the same stuff it would do right after I turned it on if I try to load the page too soon.

So why would it be rebooting on its own?

A print just failed in safe mode, so that didn't help. But see my post above. I think that gets us somewhere ...

I noticed that random startup that looks like a power cycle.

Do the power supplies have their own cable or do you have always the same one?

The power down almost always happens shortly after establishing the connection between OctoPrint and the printer.

I originally used the power supply that has an integral cable that came with my CanaKit. When I started having problems I tried 3 random phone chargers that I had laying around. None of them supplied consistently (according to my voltmeter) so I ordered the new Pi from CanaKit, which came with another Canakit power supply. The issue has occurred with both Pi's using both power supplies.

I normally run the printer, the Pi, and an LED light on the same power strip. However, I just ran an extension cable from a completely different power outlet to the Pi and had a print fail.

After tons of test prints and advice on FB, I've managed to narrow the issue down to my LCD screen. With the screen connected, it happens. Without it doesn't. I'm on to trouble-shooting the printer hardware now. Thank you.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.