Help with plugins

What is the problem?

I can't install plugins, I tried Spaghetti Dec. and Octolapse

What did you already try to solve it?

I tried using the terminal to install, tried the github link, and obviously tried the repo on the OP UI

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

Not sure how to get systeminfo bundle.

Additional information about your setup

I use OP on an HP Desktop running Ubuntu, as I can't find any RPis online for under $100, and I'm running OctoPrint 1.7.3, but my UI says 1.4.0, I ran a code to update.

Blue words like systeminfo bundle are links. You may click them for further info.

Don't see anything about systeminfo bundle in my UI, which I assume is because it's not supported. I checked my version after my post, I'm still running 1.4.0, working on getting that fixed.

Also, I'm aware blue words are links, I was reading the website the link led to.

Did you finish reading it?

The page lists a number of ways to get a systeminfo bundle. Did you try all of them?

Can you be more specific? What happens when you try to install plugins? Do you get an error message?

Yeah, it says this:
Could not parse output from pip, see plugin_pluginmanager_console.log for generated output

Yeah, I tried all the ones that were posted

I really don't mean to be snarky, but what happened when you tried? Where did you get stuck? We really cannot help you unless you are more forthcoming with details.

Did you look at the plugin_pluginmanager_console.log ? Can you share it with us?

OctoPrint 1.4.0 doesn't have the systeminfo bundle option.

If the UI says you use OctoPrint version 1.4.0, what makes you say you are running version 1.7.3? What code did you use to update? What was the output of that code? Did it result in an error?

How did you install OctoPrint in the first place? Is it installed in a virtualenv, like recommended?

Your update to version 1.7.3 likely did not work, so you are likely still on version 1.4.0.

AFAIK, version 1.4.0 did not yet support Python 3.x, so you are likely still using Python 2.x. That may be part of the reason why installing plugins does not work. But all this is guesswork without logs.

I think it is going to be less work to start over, and install OctoPrint 1.7.3 instead of trying to figure out what is going wrong upgrading from OctoPrint 1.4.0.

I ran this code
~/OctoPrint/venv/bin/pip install -U octoprint
And I cant remember the output, something about uninstalling 1.4, and installing 1.7.3, when I try to enter it again, it gives a different output. No error, and I followed this guide to install OP in the firs place, no not recommended, this

Ok, can you link a tutorial for installing 1.7.3 in ubuntu, I tried googling

It is pretty much this:

Replace "pi" with your own username.

followed that tutorial, and while it did fix my webcam problem, I still can't get plugins, same output

Ok, if I run the install command, it works, but I can't see it in the plugin manager

Fixed, i just updated my OPrint version.