Help with PSU Control settings

Octoprint PSU control

What is the problem

Currently I had the PSU control configured to pin 18. Since the upgrade the pin can not be used for both sensing and control. (Kernel 5.5 thing).

What did you already try to solve it?

I added the plug in RPi.GPIO, And configured the PSU control to point to this plug in, But I must be configuring something incorrectly. Can anyone assist with proper configuration or Is there an easier way to restore the PSU control. Sorry if this is an old issue but searching didnt find many answers.

Have you tried running in safe mode?

I disabled the PSU control and I can use my system but that control was very handy

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.131 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1400
env.hardware.ram: 918192128
env.os.bits: 32 linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.15.1
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 9.0.3
env.python.version: 2.7.13
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.1
systeminfo.generator: systemapi

Are you using the right pins?
Pin18 β‰  GPIO18

Here's the pinout

I was but there are some subtle configuration items as well. I worked and found these parameters to work.

I was unable upload the configuration. as the post would only allow 1. I have the screenshots if you would like them