Herendous wifi signal level

Hi all,

Additional information about your network
Raspberry pi 3
Prusa i3 mk3s
TPTLWN823N network adapter
Accessing with Google Chrome on Microsoft 10

I've spent the last few days trying to use octoprint via wifi. It does connect, I am able to see the IP of the machine through the router. And Octoprint works well when connected directly to the router via a LAN cable but when connecting over wifi it will continuously time out.

When I use:

sudo iwlist scan

wlan0 for the SSID I'm trying to connect to shows but with a signal level of ~90dBm which doesnt make sense. The router is <5m away (lan cable is 5m and stretches to just reach the pi). The house is timber framed with pretty thin walls, the router is raised on a shelf, and all of my other devices get excellent signal only the pi is struggling. I even tried placing the printer within a couple of meters of the router and still no luck.

I've read that the pi 3 antennas are notoriously average so I bought the TP-Link (Realtek) adapter above and still no luck. The pi has it's own dedicated 2.5a power supply and also recieves power from the printer (octoprint when working shows no issues with supply). I followed the instructions in this youtube video Easy setup of RaspberryPi 2 Wifi Dongle - YouTube after reflashing the SD card multiple times, with different sd cards, all through pi imager and to no avail. I'm pretty sure the issue is with the signal strength but it makes no sense to me why the signal is consistently soo poor. Any help would be greatly appreciated.

kind regards,

Logs (syslog, dmesg, ... no logs, no support)
let me know if there are any logs I can put up that might help.

Just some ideas - try to change the wifi channel (if possible to 1,6 or 11) and check if there is any wifi energy saving setting in your routers webui.
Sometimes they drastically reduce the signal strength if the wifi is not used much.

Ok, so this is embarrassing but I thought I should let anyone viewing this know. After days of updating drivers and trawling through .conf files for blacklists and editing with nano I finally manged to get it working. I had tried turning on and off the router and the pi multiple times with no success. Just as I was about to return the network adapter I unplugged it from the pi then decided to replug it and BAM problem solved. wlan1 shows with ifconfig command, signal strength is still pretty poor but I am now able to access the octoprint UI through my web browser. I feel like an idiot but i did learn alot about adapter chipsets and using the linux terminal so it's not a complete loss. Try unplugging the usb network adapter and replugging it.