High CPU load even while printing


I have the problem that I get permanent CPU at around 50% even while printing and it slows down the commands to the printer. I'm running OctoPi on a Raspberry Pi 3 Model B Rev 1.2. From what I could find out this can be related to GCODE analysis but should stop when printing starts. Why does it not stop for me?

Hello @MrE10!

When you opened this post, there was a template with a couple of questions to help us try and find an answer. The most important are below:

Have you tried running in safe mode, and did safe mode fix the problem?

Please upload the systeminfo bundle

1 Like

I have an older Raspberry Pi as well. My CPU runs kinda high too. I believe I ended up increasing some of the timeouts in the Octoprint Settings -> Printer -> Serial Connections -> Timeouts. Sorry, I don't remember the default values, but I've attached a screenshot of my current values. I'm going off memory from a while ago, so I may be remembering incorrectly, so keep a record of your current values.

I've tried safe mode but it didn't help. After a while I got this message in the logfile and the CPU load drop down:

2022-01-05 18:33:58,253 - octoprint.filemanager.analysis - INFO - Analysis of entry local:Schraubaufsatz.gcode finished, needed 747.09s

So I think it's actually related with the GCODE analysis

octoprint-systeminfo-20220105182352.zip (892.8 KB)

Was it a really big and high res stl?

Yes, it was around 100MB

It does seem to be related to the gcode analysis, yes. There should be some settings to control whether this is happening during printing:

1 Like

That was in deed set to always. So I guess that will help :slight_smile:
The other solution would be more CPU power I guess?

That was a rather large gcode.
Depending on what you want to print that doesn't happen to often.
My gcodes are usually 5-20MB.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.