High Resend Ratio/Communication Error [Kingroon KP3s on stock firmware]

What is the problem?

Critical resend ratio errors (~50%) on a basic test print in safe mode leading to "Communication Error". This is a brand new install of OctoPrint (OctoPi) on RaspberryPi 3

What did you already try to solve it?

Ran in safe mode and searched through existing topics to identify.

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

octoprint-systeminfo-20220817045005.zip (58.2 KB)

"Communication Error
There was a communication error while talking to your printer. Please consult the terminal output and octoprint.log for details. Error: Printer keeps requesting line 437 again and again, communication stuck"

Additional information about your setup

OctoPrint 1.8.2, OctoPi 0.18.0, Kingroon KP3S stock firmware

Running on Raspberry Pi 3 Model B Plus Rev 1.3

Although there are undervoltage warnings, it seems they are only during startup which I've seen before. You may want to verify power supply just in case. FYI, a phone charger is not a power supply. Make sure usb cables going from printer to pi are of high quality and they aren't routed directly next to stepper motors as those can cause EMI. You never answered on Discord about backpowering either. Also, you didn't try in safe mode, you should definitely do that too in case there is some plugin acting up. I see octolapse complaining quite a bit in your log.

I swapped to a better cable/power supply when I first tried OctoPrint as I got warnings. I had a Vilross PSU for a pi that was reading low but swapped it.

I do not have any backpowering happening and I did try in safe mode

The majority of cases with a high resend ratio are a result of EMI. Most of these cases are resolved by replacing the USB cable with one that is short, shielded, and has ferrite beads on both ends. Re-routing the USB cable away from stepper motors or other cables on the printer can also help. Lastly, the routing of other printer cables within the printer itself can also cause EMI issues.

EMI is one of the hardest and most frustrating issues to deal with. Perseverance will usually win in the end.

I'll try some other cables I have. I used the cable that came with the printer, but I definitely have more. In the interim, are there an good cables you'd recommend?

Every time I recommend a cable, I get the response "not available in my country" so I'll just say search for "USB shielded ferrite beads" and see what shows up in your location. I use this one.

1 Like

I have the same problem. It seems to be a firmware issue as you can read in the comment section under this article:

Basically they mixed up the firmware and microprocessor versions at soms point. I'll bet your mcu is also a GD32 F303.

For the different firmware versions appropriate for different mcu's see here:

The steps to flash the firmware can be found here, but it isnt working for me.. I must be doing something wrong.

Some are installing Marlin instead of the stock firmware, which you can find here, but I haven 't tried it yet:

This is as far as I got :wink: Please let me know what works for you.

Yep, I'm on GD32 F303 as well. What's interesting is OctoPi says its running Marlin 1.0 though that may be the default for unknown firmware :slight_smile:

How can I determine the existing firmware on the board?

This could be true, or they could be running some bastardized custom fork the way that Creality does and change the whole version number information.

Send an M115 to the printer (from the Terminal tab of OctoPrint) and the printer should tell you about its firmware including the version. You can post the output here (use the </> tool above the reply window).

Yeah their stock firmware it's a fork of the 1.x branch of Marlin. When I said 'some people run Marlin' I should really have said 'Marlin 2' :smile:

I'll give it a shot in a week or so when I have troubleshooting time! Thanks for helping confirm its dumb firmware and not a setup issue :smiley:

In the mean time I have fixed issue for my self by first formatting the SD correctly (MBR, FAT32, max 4GB) and then flashing the appropriate firmware onto the KP3S.

I posted some more info about partitioning the SD card on a Mac here: How to Fix 3D Printer Not Reading SD Card? β€” Kingroon 3D

Good luck!

Which is the appropriate firmware you installed? marlin 2.0 or the latest kingroon image?

I flashed the lastest stock firmware that matches my mcu (for me: GD32 F303). See here:

Awesome thanks! I'll try that tonight. Does OctoPrint work with the latest version of firmware?

Sure thing! I printed a lovely Low Poly Charmander for my daughter, a 3h print, with 0 usb errors via Octoprint on a Pi 3b+.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.