HLS webcam stream not working, but URL works in Browser

Camera model

Wyze Cam V2 with Docker Wyze-bridge in Home Assistant.

What is the problem?

The current HLS URL works in a Chrome browser, but when ender in the Stream URL of Classic Webcam, no video feed comes up.

What did you already try to solve it?

Changing stream URL to:

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

See attachment

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint version: 1.9.3
OctoPi version: Build 2023.10.09.154319 with "camera-streamer", based on OctoPi 1.0.0, running on Raspberry Pi Zero 2 W Rev 1.0

Browser: Chrome
O/S: Windows 11

octoprint-systeminfo-20240104220334.zip (32.6 KB)

OctoPrint only 'detects' an HLS stream if it ends in .m3u8.

I would expect that should have worked for you, based on the docs of the Docker Wyze-bridge project you linked.

Check your browser console for errors loading the stream, once you have put that URL into the classic webcam settings. It should then tell you why it is not able to load a stream.

Screenshot 2024-01-08 225349
Screenshot 2024-01-08 225403

Try disabling the 'Pretty Gcode' plugin. Based on that error it's causing a problem. I also have a vague recollection of seeing this before.

Booted into safe mode and got this whenever I inspect the "test image" location

Have you tried in an incognito/inPrivate window of your browser yet? I think you would see the next one in console tab as mixed content being blocked, but just in case, do you access the OctoPrint's web interface with http:// or https://?

I use the Octoprint web interface with http://. Same with accessing the HLS webcam stream.

Incognito mode works flawless when accessing the HLS webcam stream and incognito mode works with accessing the Octoprint web interface.

This is the console of the test image while in ingonito mode and while Octoprint is in safe mode.