Host Action Commands Message

What is the problem?

I get this message when I open octoprint after updating the firmware on my Ender 3

The link says to enabel Host_Action_Commands. I checked my firmware and it is enabled.

What did you already try to solve it?

Checked Firmware

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.45 Safari/537.36
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1200.0
env.hardware.ram: 915722240
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: True
octoprint.safe_mode: False
octoprint.version: 1.7.2
systeminfo.generator: zipapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint Version 1.7.2
OctoPi Version 0.18.0
Printer is Ender 3 (Not V2)
Firmware Marlin
Operating System Windows 10


well, you have identified the place where to enable it but as the screenshot shows, you did not.
It can be irritating but the lines in full code colors are the block of if ... end if
What you want to do is uncomment the line above,


should read


to turn that on.

Similar things have happened to me at times.

I was reading too quickly, I saw the #if line was in color and missed the line above was what I needed to uncomment. Thanks for your help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.