Hostname Issues - about to pull my hair out!

What is the problem?

Cannot find the settings or method to get into terminal and change the host name so I can run two OctoPi Servers

What did you already try to solve it?

Tried following the GitHub instructions provided by GuySoft, extensive internet searching

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint Ver 1.7.0, OctoPi Ver 0.18.0 on RPi 4B Rev 1.2, Creality Ender 3v2 on Stock Firmware, OS X operating system running Safari and Brave to access via browser.

Thanks in advance!

You don't say if you can ssh into the PI
If so, then login to the Pi as the pi user and run the raspi-config command and select System Options, there, you will find an option to change hostname.
raspi-config has to be run as root so:

sudo raspi-config

Reboot the system after the change.

If for some reason you can't ssh into the pi, then you'll have to connect a mnitor and keybord to login.

Holy cow, I just figured out why I wasn't able to SSH into the Pi before.

Thanks for your comment making me think that I had to be missing something obvious.

Will mark as solved, cheers.

For the benefit of other people stumbling onto your post: what obvious thing did you miss?

1 Like

I was really hoping nobody would make me admit it, but I was using the wrong password to log into the pi via SSH.

I had assumed since I was trying to edit a pi that was already configured otherwise that the password for SSH would be the same as the one I use to log into my OctoPrint instance.

1 Like

No worries. Such things happen to all of us.

Welcome to the Club :sunglasses:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.