Hostname Issues?


#1

What is the problem?
Hi, I have 2 raspberry pi's running octoprint. Both are set up and running fine. Both are running octoprint 1.3.8 and octopi 0.14.0. I named each pi for the machines they are attached to through raspiconfig. When I log in, one shows octoprint in the top left of the header and the other shows the name of the machine. Not sure what I did different between the two. They do show up on my network with the correct names. Any suggestions would be greatly appreciated. Thanks!

What did you already try to solve it?

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)


#2

Each host on your network should have a unique hostname. This will help name-resolution services like Bonjour and DNS so that you can find the computer uniquely by its name.

This sounds like you have two Raspberry Pi's each with a hostname of "pi". Why not name them "pi1" and "pi2" or "fred" and "ginger" or anything that's different?


If you cloned the image from the first Raspberry Pi and copied it to the second, then you might need to edit the ~/.octoprint/config.yaml on the second. From what I remember, there's a upnpUuid value in there which should be unique across both Raspberry Pi's.


#3

@OutsourcedGuru I think you misinterpreted what @jerricho1422 said. I believe each Pi is named for the machines (i.e. printers) they are attached to (and this was done using raspi-config).

I have 2 Raspberry Pi's (a 3B running OctoPi 0.14.0 and a 3B+ running OctoPi 0.15.1) and both of them have "OctoPrint" in the top left of the header on the HTTP page.

The "magic" that @jerricho1422 wants revealed is how one of them changed this to the host name of the Pi (probably because he likes that magic and wants to repeat it on the one that still says OctoPrint).


#4

I believe the answer is OctoPrint Settings, Appearance, Title. You can put whatever you want in the top left of the header.


#5

Thank you! I overlooked that in the settings.