Hot end not heating up when I stream a GCODE to the Pi

What is the problem?

After transferring a gcode file to the Pi from my PC, the hot end doesn't heat up, yet if I put the same gcode on the micro sd card in the printer, then start the print from Octoprint, it prints perfectly, is the gcode being corrupted during or after transferring to the Pi maybe?

What did you already try to solve it?

No idea how to solve the problem

Have you tried running in safe mode?

Not tried

Did running in safe mode solve the problem?

Not tried octoprint.log (609.1 KB)

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

Pi 3B+ running Octoprint Version 1.5.3 connected by serial cable to a Sunlu S8 with a class 10 Sandisk micro SD with a Windows 10 computer running Simplify3D as a slicer

Could you upload the gcode?

1 Like

Unfortunately not, I tried, but the gcode exceeds the upload limit :frowning:

You may zip the gcode file...

Yes that made it way smaller (2.2 MB)

So we have this here:

M104 S235 T0
M109 S235 T0
G28 ; Home all axes
G92 E0 ; Reset Extruder
G1 Z25.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
G1 E45  F300 ; Purge 45mm
G92 E0 ; Reset Extruder
G1 X160 Z.1 F3000
; End of custom start GCode
G92 E0
G1 E-4.6000 F2100
G1 Z0.600 F1000
; process Process1
; layer 1, Z = 0.600

You are heating up tool 0 (T0) and then you switch over to tool 1 (T1)
If you want to perform a dual extrusion mode, you also have to heat up T1.

1 Like

How strange, I only have single extrusion, tool 1 is identified as the primary extruder in the Simplify3D printer settings maybe I should set that to tool 0 and see what happens?

1 Like

It's worth a try anyway.

I'll post back and let you know, thanks for your help :slightly_smiling_face:

1 Like