Hotend and bed shutoff at the beginning of the print?

What is the problem?

Just downloaded the new version of octoprint and am using the newest version of cura. Every time I start a print on my CR10s pro v2, after the prime blob the hotend and bed shut off but the printer keeps going through the motions. The only plug-ins I’m using are octolapse and spaghetti detective.

What did you already try to solve it?

Tried re slicing and checking my settings

We can't help you without logs.

octoprint.log (3.6 MB) plugin_octolapse.log (15.7 KB) plugin_pluginmanager_console.log (22.6 KB) plugin_softwareupdate_console.log (9.4 KB) serial.log (148 Bytes)

this is what i could get to transfer over to here, the others wouldn't drop in.

Enable serial.log, reproduce your issue, then upload the resulting serial.log again. Yours is currently disabled and thus empty.

Your octoprint.log also contains a line that looks like data corruption, if you are in the habit of just pulling power from your Pi then immediately stop doing that, always shut down via the system menu first or you risk file system corruption and a broken installation.

I reinstalled Octoprint, and reproduced the issue with serial logging turned on, this is the results of that. thank you for the assistance it is greatly appreciatedserial (3).log (90.7 KB) .

I've found that if I pause my print right after it shuts off the hot end/bed (immediately after preforming the prime blob) and set my temperatures in octoprint, let it heat back up, then resume the print it seems to print fine. it seems that its something immediately following the prime blob before beginning the actual print, where something is telling it to shut off the bed and hot end?

Update: its shutting the hot end and bed off at layer changes as well.

It sounds like it could possibly be a gcode issue. Have you tried printing off sd or a different program like pronterface? That would tell you if octoprint is the issue. What slicer are you using?

2021-01-27 02:42:30,787 - Recv:  T:204.97 /205.00 B:65.00 /65.00 @:65 B@:23
2021-01-27 02:42:30,819 - Recv: ==onPrintTimerStopped==
2021-01-27 02:42:30,835 - Recv: ==onConfigurationStoreWritten==
2021-01-27 02:42:30,947 - Recv: Not SD printing
2021-01-27 02:42:31,938 - Recv: Not SD printing
2021-01-27 02:42:32,786 - Recv:  T:204.86 /0.00 B:64.87 /0.00 @:0 B@:0

So what I see here is:

  • target temperatures are 205 and 65 degrees
  • the firmware says something about a print timer being stopped
  • after that the target temperatures are 0

Looks to me like this firmware has some idle temperature off functionality and you are missing something in your slicer's or OctoPrint's start GCODE script to tell your printer's firmware that you are in fact printing via serial.

I cannot tell you what that is however, I don't know what firmware you have running there. If it's Creality stock firmware, reflash standard Marlin, these forums are littered with issues with Creality firmware.

I’m currently using tinymachine's firmware they had on their website for this printer, as of about a month ago when I flashed that firmware onto my machine. Odd thing is, I had octoprint running and working about 2 weeks ago on the previous version of octoprint with my currant/the newest version of cura.

I’m using the newest version of cura. I haven’t tried using any other ways of printing since I downloaded the previous version of octoprint about 2 weeks ago and i was able to print fine from octoprint then. Before that, using this same version of cura, I was able to print from my SD card with no issues but haven’t tried off the SD card since.