How can I RESET the different Log files?

What is the problem?

I recently installed the Print Time Genius Plugin and there is an option to Analyse a file and look at the log it produces.
However the log file was full of data so I wanted to Clear it out/Reset it so that when I anaylsed the STL I would not have to wade thru heaps of previous logging data. There was NO option to reset the log file - only to Delete it in the Octoprint Logging section of Settings. So I clicked the Trashcan and deleted the log that was there.
Running the Analysis again, produced no log file. When I clicked on the link in this plugin setting page it took me to a 404 error-not found. This seems to be there for other logs as well. No way to reset them and if once deleted no way to recreate them!!
I was only able to get a log file to appear again by first uninstalling and then re installing the plugin requiring a reboot each time

What did you already try to solve it?

Uninstall/Reinstall plugin

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs


Additional information about your setup

Latest version v1.5.3

Is there an easier way to reset a particular log file in Octoprint without going thru this rigmarole of uninstall/install?
By the way there is no option to Reset ANY of the Octoprint logs or at least that I have (not) found.

Actually, probably what happened is the file was gone until a restart of OctoPrint, and therefore couldn't be written to. So in theory, delete the log file, restart OctoPrint for it to re-initialize the plugin's default log file and then everything should log as expected from there.

I use OctoPrint Settings (wrench icon), Logging and then the trashcan icon next to each logfile to delete any (or all) the log files. Then I use the OctoPrint Power (icon), Restart OctoPrint and all the logs come back with fresh (or no) content.

1 Like

Thank you @jneilliii and @b-morgan for your replies. This solved my query.