How do i change the OctoPrint Port assignment in WINDOWS version

What is the problem?

I am trying to setup octoprint everywhere so I can monitor when I am off my LAN. LAN Access works fine based on the localname and port link. To gain access via WAN I know I need to setup a dynaminc routing rule on my router based on the port and static IP of my windows machine running OctoPrint. I already have an NAS on port 5000 and its a lot easier to change this one device then update everything already accessing the NAS. How do I assign the Port I want and the IP address? When I would start the server I was getting an error in red about the IP address but when I look now (and Im printing atm I dont see that error)


What did you already try to solve it?

I see no options in the webpage gui to change this. I found 1 post but that was based on an update to a linux structure

Have you tried running in safe mode?

The server runs OK>

Did running in safe mode solve the problem?

dont know how that would help

Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 16
env.hardware.freq: 1801.0
env.hardware.ram: 16540987392
env.os.bits: 64 windows
env.os.platform: win32
env.python.pip: 23.3.2
env.python.version: 3.11.7
env.python.virtualenv: True 2024-01-31T00:29:15Z
octoprint.last_safe_mode.reason: incomplete_startup
octoprint.safe_mode: False
octoprint.version: 1.9.3
printer.firmware: Marlin Creality 3D
systeminfo.generated: 2024-02-03T20:05:53Z
systeminfo.generator: zipapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint Version 1.9.3
Ender 3 Max with the BL Touch Merlin Firmware
Currently using Google Chrome on a Windows 11 Pro PC
MicroPC has a STATIC IP and a WiFi connection. Not using ethernet.
OctoApp 2.0 (again works on LAN (ie my wifi
Thank you in advance!


Hello @dbreslin42 !

Short hint:

you are a SNARKY bunch arent you.
I copied the detail from the system file of the bundle.
Hmmmm I love asking for general adjustments to simple STANDARD configurations and being asked for mothers maiden name, DOB and social security number. Why not ask for my windows key?

Hey if you dont know, dont answer... sure beats deflecting and blaming others.
You have a complete assessment of everything you need to provide adequate guidance.

To be fair, there are actually helpful hints in that bundle that would aid in us answering your question. For example, did you do the manual windows install steps or use the windows installer? With the system info bundle I could have figured that out myself. The reason that information is important is because the answer will be different based on your response to the above.

Sure and you are...

When it is asked for the bundle, the please provide the bundle. (560.2 KB)

thats what the octoprint internet webpage under about Octoprint\System Information

That's fair. I just have struggling with this for 3 weeks 1st with a raspberry Pi5 that was actually DOA and now a windows micropc.
I think i have most figured out except the octoprint bed leveling. I have a cr touch on my ender 3 max and while it has helped some, I am finding that on larger prints I'm having some, not all, of the edges lift up. The CR touch levels the bed in 9 points and i know Cura (my slicers) knows how to read that firmware to help with the unleveled areas but I am hoping OctoPrint does to... and yes I added the BL Touch plugin.
I'm learning as I go but i am hitting these instances where I have to take a step or 2 back. What I do know is before I integrated octoprint I had a few amazing prints... but seem to have regressed a bit. Hoping its just tuning.
Thank you for explaining why and I have attached the zip bundle file it generated yesterday

OctoPrint has nothing to do with beef leveling and there is no specific need for the bltouch plugin for it to work. That's all managed/handled by your firmware, but what you describe sounds like curling/eating to me.

so i finally got the bed leverel/imager to work and it was way off ... tried fixing it and rerunning over and over but gave up and did the paper test and reran the firmware 9 point bed level. Just went to print a bed level square test and YUP since curling. I cleaned with rubbing alcohol this AM but just added some bed weld. also dropping the initial layer bed temp by 5 deg

BTW when I said i think I figured it out, i did not mean changing the port. I still would love a tip there. I attached that system bundle above as requested.
Thank you

oh, to me that meant you figured everything out already, including the port. I see you did not use my windows installer, so I'm curious how your OctoPrint is configured to startup? Do you use a batch file or a shortcut or did you go the extra steps to create it as a service?

Basically, however you are starting it you need to append the command line parameter to it like the below template, which is setting the port to 5001.

C:\OctoPrint\venv\Scripts\octoprint.exe serve --port 5001

Wow if its that's easy that is awesome!
Thank you so much!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.