How do I use a service file to fix a problem

What is the problem?

I have encountered a problem with the wifi setting not changing. and there is a work around solution posted that I am sure will fix my problem. see: " Service file to fix symlink for wpa_supplicant.conf #337". But I am a noob at linux and I do not know how to apply this fix. I know enought to use putty to log into my octopi server and a few linux commands such as ls cp, rm, cd etc.

What did you already try to solve it?

I have verified that the link to the wpa-suppplicant.conf is broken with the ls -l command
-rw-r--r-- 1 root root 139 Dec 4 21:56 wpa_supplicant.conf

I have been able to modify the wpa_supplicant.conf file using nano editor, and the system is now working, but I would like to apply the fix so I can update the network "octopi-wpa-supplicant.txt" settings on the microSD card using windows.

If you're using OctoPi 1.0.0 there is a service file already there, you just have to enable it in octopi.txt. At the bottom of the page there is this section.

# Configuration of network monitoring
# This enables network monitoring for wifi connections with a simple ping test.
# If connection terminates by variable reasons system tries to restart the wifi connection to reestablish a connection.
# The connection test is done every minute.
# By default it is disabled (0 = off / 1 = on)
# destination_host can be an ip address or a hostname (for hostname ensure dns resosultion is working correctly)

just change the 0 to 1 and update the ip address of the destination_host to your router's ip address and reboot.

I don't think that's what the post is asking - they don't want network monitoring.

It sounds like the symlink between octopi-wpa-supplicant.txt and wpa_supplicant.conf is broken. It happens sometimes.

There is one command to fix it - it doesn't require a service or anything, without a link to where you got that solution from I can't tell what it's referring to.

The command you need is:

sudo ln -s /boot/octopi-wpa-supplicant.txt /etc/wpa_supplicant/wpa_supplicant.conf

That should restore the link. Please check the paths are right, I've just typed them from memory.

Thanks a million for the quick response It worked! That was the answer I was looking for. and your spelling is perfect. :grinning:

As I was playing with it I discovered, that I had to remove the original file that lost its link, other wise I got an error saying "ln: failed to create symbolic link '/etc/wpa_supplicant/wpa_supplicant.conf': File exists"

sudo rm /etc/wpa_supplicant/wpa_supplicant.conf

PS for anyone reviewing this post the original message about a Service file.