How to disable python3 zeroconf in octoprint?

What is the problem?

TLDR: Octoprint uses python's zeroconf Multicast DNS Service Discovery. How can I disable it?

Long version: Octoprint's zerofconf mDNS Service messes with avahi-daemon running on my system, because hostnames are not stable. The first mDNS service up get's the mDNS hostname of, for example, 'host.local', the second service 'host-2.local' and the third service 'host-3.local'. avahi anounces my network share containing my central Backup location and computers expect to find it under 'host.local'. If avahi-daemon does not come up as first mDNS service, it will find the name 'host.local' to be already taken and will fall back on 'host-2.local' or 'host-3.local'.

So my question is: how can I disable octoprints zeroconf integration?

What did you already try to solve it?

I stopped the octoprint services manually. That solved the problem, but is of course not a solution. Ideally, I would like to avahi announce all services on the system, including my octoprint instances.

Disable the 'Discovery' plugin in OctoPrint.

1 Like

Awesome, thanks. I wasn't aware that there are any plugins active by default.