How to downgrade to python 2 version?

Upgrading Octoprint to python3 has been the worst idea ever, a rabit hole of problems after problems. How can I downgrade or does someone have a link or version where I can install the old octoprint with python 2.7?

Wasted so much time, like 3 hours trying to figure out why my bed leveling program wouldn't run. Ugh.

you can find and download outdated, old and ancient versions of octopi at:

Just take care to disable software update and only install plugins from file so that you can restrict your usages to fittingly outdated plugins.
I'm sure there is a better solution though

How about telling us what the problems are, so that we can help you fix them? Hundreds of thousands of people have upgraded already so there must be something we can do to make it work.

1 Like

I spent about 2 days literally maybe 10hrs trying alternative plugins, direct through klipper, etc.

There’s no better bed leveling script than a 4 year old one that runs on Python 2.7. It’s not being maintained, and I’m no programmer. But I used it and it worked flawlessly for over 2 years.

I tried mainsail also, but I decided even though mainsail was 20x faster, and more visually appealing, I couldn’t do without this plugin. Lo and behold, upgrading Octoprint is worse than the old version that runs on Python 2.7. It’s still slow as molasses but now it doesn’t have the best plugins either. No choice but to downgrade🤷‍♂️

The plug-in is a fork with added functionality:

I tried a couple plugins in the Octoprint directory already but none were satisfactory, some of them ask to turn the screws in a different direction due to different mounting type. I also tried the automated klipper bed screw calibration tool, but wasn’t getting the same accuracy perhaps due to my error setting up the points or the algorithm being used.

The issue is that when you enable the plugin and reboot, the plugin gets disabled. The tab that shows up in 2.7 doesn’t show up and the plugin never activates.

The log shows this error, “ TabError: inconsistent use of tabs and spaces in indentation.” It seems simple enough but I’m not much of a programmer. I tried to run it through a Python format script but that caused new errors. Not sure if it’s simply an indentation problem or the underlying coding issue lurking beneath. Python is beyond me at the moment.


It's not marked as Python 3 compatible so if that's a blocker you can ping the dev and ask for Python 3 compat version or go back and stay on OctoPrint 1.7.3(max).

Just came to looking at what needed to be done on the plugin to fix it and provide a patch, and I see the author has just fixed it as well! So there we go I guess there's no excuse not to use Python 3 now :wink:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.