How to get last version of libgtk (dependency)?

Hi people!
I'm trying to install octoscren and it depends on a new version of GTK3+.
As you can see in the error message, I have version 3.14.5 installed.
I tried several ways to force update the installed version to update to the last version but without success.

Unpacking octoscreen (2.2-2) ...
dpkg: dependency problems prevent configuration of octoscreen:
octoscreen depends on libgtk-3-0 (>= 3.21.5); however:
Version of libgtk-3-0:armhf on system is 3.14.5-1+deb8u1rpi1rpi1g.

dpkg: error processing package octoscreen (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:

From the octoscreen forum, a guy told me is some kind of problem-related to the octoPI.
I'm not advanced on Linux or python but I can follow some tutorials.
To have an idea, I have a Robo R2 printer.
I manage to "unlock" the updates installing new versions of octoprint/pi/python/OpenSSL but now I'm stuck on this step... install a new screen.
When I changed and updated the Robo version of Octoprint, the display stopped working. So I thought if I install a new plugin for display, I can continue to use the original display.
Could someone help me, please?

Looks like your raspbian is still on jessie.

I suggest you back up your octoprint, flash octopi 0.17.0, restore the backup and try it again :slight_smile:


Basically I just edited the repository to the new one and it worked.
But in the middle I started a new fresh installation of the raspian... well if we are change everything, better to start from the began.

1 Like