How to install octoprint 1.4.0 with python 3

What is the problem?
I have no idea on how to install octoprint 1.4 on my pi 4 with python 3 and can't find a guide either here or anywhere and since there's support for it I'd rather use python 3 than the eol python 2.7
What did you already try to solve it?
Tried changing the commands on Setting up OctoPrint on a Raspberry Pi running Raspbian from python/pip to python3/pip3
Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible) 1.4.0, ender 5 pro, marlin, edge chromium, raspbian buster, windows 10, pi 4 4gb

1 Like

I guess it would help of you share the terminal output so we can see what's going on.

I'm sure there will be a python 3 guide soon :slight_smile:

Just create the virtualenv with --python=python3

virtualenv --python=python3 venv
1 Like

It worked (I think, since it didn't give me any error regarding python 2 EOL), thanks!