How to re-deploy OctoPrint by Python 3 in Raspbian?

Hi everyone:

I am developing a Plugin in OctoPrint for my research study currently, the codes for developing the plugin is written based on the Python 3 environment. However, when I tried to install the Plugin package, the Plugin manager displayed 'ERROR: Could not install requirement'.

In my opinion, it should be the issue of Python developing environment, I am trying to change the developing environment from Python 2 to Python 3. The UI of Plugin manager shows the following information:

Using pip of "/home/pi/oprint/bin/python2", Version 19.3.1
Installation directory: /home/pi/oprint/lib/python2.7/site-packages ("--user" flag: no)
Virtual environment: yes

I tried to reset the developing environment in my Mac's command, but it doesn't work. My OctoPrint version is 1.4.0. I also followed the tutorial of 'Migrating to Python 3' to get a Python 3 virtual environment with OctoPrint, but I still cannot install the developed Plugin. The following information is I copied from the log file after I tried those methods:

2020-04-04 00:49:13,214 - octoprint.plugins.pluginmanager - INFO - Installing plugin from*/*/archive/
2020-04-04 00:49:13,220 - octoprint.plugin.core - DEBUG - Parsing plugin metadata for pi_support from AST of /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/pi_support/
2020-04-04 00:49:18,625 - octoprint.plugins.pluginmanager - ERROR - Installing the plugin from*/*/archive/ failed, could not parse output from pip. See plugin_pluginmanager_console.log for generated output

Could you give me some direction on how to solve this issue, and set up and re-deploy a Python 3 environment in Raspbian, then I could install my Plugin? I appreciate any advice, suggestion, and help. Last but not least, please stay safe and keep fit during this particular COVID-19 influenced period.


Check out the docs here.