How to take Octoprint OFF of autoload


#1

I have loaded Octoprint onto my raspbian RASBERRY PI and want to take it out of auto load on boot up.

I followe the directions on the github but dont really knows enough to change it back to manual loading from the automatic load on startup.

I have raspberry pi 3 (newest you can get) everything is up to date as per last sunday (7-1-2-18). running raspian and loaded octoprint as per instructions on foosel's github page.

Wanted to be able to use either octoprint or Repetier. so don't want either to autoload.


#2

What version of Raspbian?

If it's stretch based, try sudo systemctl disable octoprint.


#3

with the program os-release i get:

pi@octopi1:/etc $ cat os-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=raspbian
ID_LIKE=debian

if that helps. I am a newb to the linux environment so I have to look up how to do everything. although when younger i was a VG programmer in the 8086 days.


#4

sudo systemctl disable octoprint

says:
sudo: systemct1: command not found


#5

that's a lowercase L, not a one.


#6

well that did something.

octoprint.service is not a native service, redirecting to systemd-sysv-install.
executing: /lib/systemd/systemd-sysv-install disable octoprint


#7

I think that's correct. You can do systemctl status octoprint to check.


#8

octoprint.service - LSB: OctoPrint daemon
Loaded: loaded (/etc/init.d/octoprint; generated; vendor preset: enabled)
Active: inactive (dead)
Docs: man:systemd-sysv-generator(8)

is what i get and that looks offline to me.


#9

and i'm assuming this is the way to start octoprint back up:

sudo service octoprint restart


#10

yeah, seems right.

Or just start (instead of restart).


#11

That did it and thanks for both of your help!