Hyperpixel 4.0 not working after new image install

What is the problem?

After updating my Raspberry Pi 4 to OctoPi 1.0.0 with OctoPrint 1.10.0 (Build 20240425094544) via Raspberry Pi Imager, and installing the SD card back on the Pi, I was able to successfully log into Octoprint, and start controlling my Prusa MK3S. I noticed that there was no image on my HyperPixel 4.0 touch screen though. The screen was on as it had a very faint backlight illuminated, just no image.

I went to GitHub to install the HyperPixel 4.0 drivers, via SSH in putty, "curl -sSL get.pimoroni.com/hyperpixel4-legacy | bash" and everything seemed to run OK. After a reboot, still the same issue.

I have tried to re-image the SD again and again, no success. It is to be noted, that this setup has worked for me for 3+ years, when i first added a Raspberry Pi to my Prusa. I only just decided to update the SD as I was still running Python 2 I believe, and I was tired of going into OctoPrint and getting the message that it was time to upgrade, so as i was replacing the Nozzle, and upgrading the printer firmware to 3.13.3-7094, I figured it was a goodtime to update... I was wrong.

Any guidance as to why my HyperPixel has stopped working after updating my Pi?


My guess is that the version of Debian that the Raspberry Pi OS is based on changed and the Hyperpixel 4.0 drivers need to be updated. OctoPi is just a repackaged version of Raspberry Pi OS Lite.

See the Software section of this web page. If that doesn't fix the issue, you probably need to ask Pimoroni support.