Hyperpixel 4 can not rotate at all

Good Evening , im having a real hard time her with the HyperPixel 4 tft screen and Pi4 1 gig board. I printed all the enclosure pieces and have everything mounted up to my Prusa MK3s but i can not get the screen on this thing to rotate. i have tried all the simple steps as hyperpixel4-rotate left and i get this

pi@octopi:~ hyperpixel4-rotate left Rotating display Can’t open display [sudo] password for pi: Traceback (most recent call last): File “”, line 3, in ImportError: No module named screenlayout Setting matrix: 0 -1 1 1 0 0 Unable to connect to X server Saving touch settings to /etc/udev/rules.d/98-hyperpixel4-calibration.rules pi@octopi:~

i have even tried all of this

  1. Update your bootloader!.
  2. Read the instructions from https://wiki.ubuntu.com/X/InputCoordinateTransformation
  3. Run sudo apt-get install xinput
  4. To get your device name run FRAMEBUFFER=/dev/fb1 & DISPLAY=:0.0 xinput list
    use /dev/fb0 if you’re using HDMI or the Official RPI display
  5. Create a new file touch ~/TouchUI-autostart/calibration.sh
  6. Edit the new file nano ~/TouchUI-autostart/calibration.sh
  7. Copy su $TOUCHUI_USER -c "xinput set-prop 'YOUR DEVICE NAME' 'Coordinate Transformation Matrix' 0 1 0 -1 0 1 0 0 1"
  8. Replace ‘YOUR DEVICE NAME’ and the coordinates with the instructions from the ubuntu wiki.
  9. Save & Exit (CTR-O, ENTER, CTR-X)
  10. Reboot

and this DISPLAY=:0.0 hyperpixel4-rotate left
Rotating display
/usr/bin/hyperpixel4-rotate: line 18: xrandr: command not found
Traceback (most recent call last):
File “”, line 3, in
ImportError: No module named screenlayout
Setting matrix: 0 -1 1 1 0 0
/usr/bin/hyperpixel4-rotate: line 10: xinput: command not found
Saving touch settings to /etc/udev/rules.d/98-hyperpixel4-calibration.rules

The xrandr to the best of my knowledge is a CLI tool within the x windows system, (the GUI Desktop) which accompanies the Raspbian Buster Desktop version of the operating system. It's likely that you have the Raspbian Buster Lite version, I'd guess.

You should be able to adjust both the display rotation as well as the touch-screen input in the /boot/config.txt file.

Video options
Also, read this.

i can honesly say that now after a few months the HyperPixel 4 screen is one of the worst products i have every purchased. Its so incredibly difficult to get anything done for screen configuration. After several weeks of messing with this thing and wasting so much time its finally hoizontal but the friggin touch interface for left and right are reversed and cant seem to find any way to correct. the up and down works great. i hate this POS

What did you do to rotate the actual display in the end?


Are you also on a pi 4 or is this general hyperpixel 4 rotate question?

PI4, exact same issue, tried everything, I can figure out how to rotate the touch interface but not the display..

Are you trying to rotate it in ssh or on the pis console?

Tried both

after some VERY aggravating days and hours wasted i contacted Ada fruit where i bought it and just returned the piece of garbage. went with a different 3.5 " display works perfectly. Such a shame that 3 different products by Pimoroni that i have tried to use and ALL of theme turned out to be massive headaches. i wont be buying their products again .

Sounds like this.

cd /boot
Sudo nano config.txt

Under PI4
Ad line under : max_framebuffers=2
Add: display_lcd_rotate=1,2 or 3
Depending on where you want the screen rotated too..
U might need to add # before : dtoverlay

This should turn the direction on the screen..

If you need help turning the touch, let me know