I can conect and ssh into the octopi but I can't access the internet with it

What is the problem?
Octoprint does not connect to the plugin repository , github or google.
What did you already try to solve it?
Check and make the "octopi-wpa-supplicant" is ok , if it can connect to which it can.
Logs (octoprint.log, serial.log or output on terminal tab, ...)
octoprint (1).log (514.9 KB)
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, ...)
Newest OctoPi and everything up to date.

I had to reset my router today , not sure if it affects this in any way.

If you can ssh into OctoPi, then the local network is probably configured correctly. The commands "ifconfig", "route", and "nslookup google.com" should verify that (is "dig" installed? If so, "dig google.com" would also verify that DNS is working).

Resetting the router could have improved the situation. My guess is that DNS isn't working.

Ifconfig returned :

eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:3a:29:02  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 1173  bytes 203710 (198.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1173  bytes 203710 (198.9 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::1fb8:413:cf27:c60c  prefixlen 64  scopeid 0x20<link>
        inet6 2a02:2f08:5705:a500:b84d:2b3e:fbd8:40d2  prefixlen 64  scopeid 0x0<global>
        ether b8:27:eb:6f:7c:57  txqueuelen 1000  (Ethernet)
        RX packets 490  bytes 62368 (60.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 132  bytes 29604 (28.9 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Route this:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         UG    303    0        0 wlan0   U     303    0        0 wlan0

Jslookup google.com returns only a error.
Dig is not install.

Looks exactly like I was expecting based on your symptoms. DNS is not configured correctly on OctoPi or your router isn't responding to DNS requests. Please provide the output of "cat /etc/resolv.conf" and the error from "nslookup google.com" (I'm assuming that Jslookup was a typo). Can you "ping" from OctoPi?

It's probably also a good idea these days to remind users that PiHole on their network loves to swallow the Raspi's attempts to fetch updates.

I will do this when I get home.

I did not install that , couldn't get it to work so I just cleaned the sd card just to be sure it's gone.

Hi , I am sorry this took so long , but here is the output of "cat /etc/resolv.conf":

Generated by resolvconf

Not sure why but "nslookup google.com" returns only a bash , command not found error.

I can ping

Have you already tried ping google.com ?

Just tried it , it returns something along the lines of " Temporary failure in name resolution".

So it seems your RasPi has no connection to the router.

By the way, IP is very unusual.
More common are 192.168.x.y

From my "noob"-ish understanding is a DNS created by Google.

Yep, you are right.
So, are you accessing the internet with your PC via the same router?

Yes , the Pi doesn't want to access the internet , but all the other devices in my house can and access it on the same network. As mentioned above by @b-morgan I think this is something regarding the DNS.

It is something regarding DNS, your RPi has no DNS servers configured (as evidenced by /etc/resolv.conf). The IP address is (one of) Google's DNS servers.

Your router is not supplying DNS servers when the RPi requests an IP address via DHCP. That may be harder to fix than just adding some DNS servers to the RPi manually. To do that, please follow the instructions in https://pimylifeup.com/raspberry-pi-dns-settings/.


Thanks for the reply , I will follow that guide when I have time.

Adding the DNS servers to the Pi solved this, thanks for the help!