I can not reach octoprint after update

What is the problem?

I tried to upload octoprint (1.3.11 to 1.3.12) and bed mesh plugin this morning. octoprint page connection gone during uploading process. After attempting to load page I got this message a few minutes later:

What did you already try to solve it?
I chekced running processes. There are no running processes for Octoprint:


Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...)
octoprint.log (37.5 KB)
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ...)
I am using klipper.
My octoprint version is unknown.
OctoPi version is 0.16.0


What happens when you run

~/oprint/bin/octoprint serve --debug

Nothing happened.

Something got seriously messed up with the installation then. Did you have any errors during update about not being able to write to the file system or something like that? Are you in the habit of simply pulling power without shutting down the system properly first (if so, stop doing that)? How old is the SD card?

In any case, try the following:

~/oprint/bin/pip install -U OctoPrint==1.3.12

I didn't get any error messages during installation. I just got server is offline message during installation. I always pay attention to shutdown raspberry with proper method.

Command result is:

Ok, next attempt:

~/oprint/bin/pip install -U --force-reinstall OctoPrint==1.3.12

Note the additional --force-reinstall there.


This time it worked. Thank you very much.

1 Like

So everything running again?

If so good, but you should force an fsck run to rule out that your filesystem is corrupted.

1 Like