I cannot connect MK3S+ to Octopi

sorry,my english is poor ,i copy the text someone like me

What is the problem?

I am having the issue of not connecting...timing out...offline.
I have Prusa MK3S+ connected via USB cable.
I have changed Cat 5 cables.
I can monitor my webcam, both from my pc and iPhone. I cannot connect, tranfer, nor control from either.

What did you already try to solve it?

I have changed Cat 5 cables.
I have rebooted both the Raspberry Pi and PC, tried different USB ports on Raspberry
Also tried in "safe mode"

serial port /dev/ttyACM0
Baudrate 115200

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20220815104150.zip (44.6 KB)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Hello @ace450586793 !

Have you set the Prusa firmware for using USB?

For USB, you have to set off

thank you for reply
my printer RPi port is off

Just for clarification:
CAT 5 cables are for LAN connection and do not influence the USB connection of the Pi to the printer.

Have you tried different USB cables too?

yes,i have 2 cat5 cables and i have changed it

Have you done this?

yes i have done this

You may try more than two or three. Power only cables can't be distinguished from data cables on the first sight.

sorry,I said it wrong
i have changed 2 data cables already.
and it does't work

You may try more.
Some users found a working one with 1 out of 6.

You can recognize a good data cable by the ferrite beads at the ends and that they a thicker than a power only cable.

but my data cables can connect before

Can you then share the systeminfo bundle

I uploaded this

Sorry, overseen that

You may try to connect to Pronterface running on your PC

Hello @Benoit_Naud !

The OP never mentioned that.

From the log:

|  plugins:
|    pi_support:
|      model: Raspberry Pi 3 Model B Rev 1.2
|      octopi_version: 1.0.0
|      throttle_check_enabled: true
|      throttle_check_functional: true
|      throttle_state: '0x0'

The OP has a connection to the Pi. So why that?

my mistake sorry , I read too fast
I get confused with the cat5 cable and the rpi zero setup om MK3S

1 Like

I believe you are confusing us by using "cat5 cable" when we think you mean "USB cable". The connectors are vastly different so you should be able to tell them apart and I don't believe the MK3S+ has an ethernet cable connection. Perhaps you can take a picture of the ends of the cable and post it here?

sorry , my english is bad. i mean i have changed USB cable but it does't work

Hello, I connected mk3s + to the PC, and then prompted that the hardware could not be recognized. Then I rewrote the driver and official firmware for mk3s +, and octoprint can be connected. It's been used normally for several days. Today, it can't be connected as before