I can't get the BTT filament sensor to work

What is the problem?

Greetings everyone. I'm using a BTT smart filament sensor with an Ender 3 V2 and Raspberry Pi 4. Every time I test the sensor, it doesn't work.

I've tried cutting the filament as well as pressing the lever on the extruder but the sensor never pauses the print job.

What did you already try to solve it?

I have the cable from the sensor plugged into the RPI header at 3 of the 4 pins recommended by the GitHub page for the Smart Filament Sensor plugin. I think mine are 13, 15, and 17. This diagram shows the pin numbers for the RPI header and here's where I plugged in the cord. Is there a certain orientation the cord is suppose to be plugged in?

Here's a screenshot of my settings in the Smart Filament Sensor plugin. For the GPIO pins field I have it set to "13 15 17". Am I only supposed to have one number? I tried one number before, but nothing changed.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, what kind of hardware precisely, ...)

  • OctoPrint version 1.8.6V

  • OctoPi version 0.18.0, running on Raspberry Pi 4 Model B Rev 1.5

  • Ender 3 V2

  • Using the M115 command in the console it came up with this:
    "FIRMWARE_NAME:Marlin E3V2-Extensible-UI (Jun 6 2021 13:54:31) SOURCE_CODE_URL:github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:Ender-3 V2"

  • Board number says 4.2.2.

Thanks in advance for any help with this.