I can't install any plugins. error: subprocess-exited-with-error - exit code: 255

What is the problem?

I am unable to install any plugins either via the plugin manager or cli.

What did you already try to solve it?

Tried installing plugins both through the manger and ssh

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20230420213714.zip (6.3 KB)

Additional information about your setup

Version 1.8.7, Debian 11, Ender-3 S1 Pro, Chrome

error: subprocess-exited-with-error
Γ— Getting requirements to build wheel did not run successfully.
exit code: 255
Could not import OctoPrint's setuptools, are you sure you are running that under the same python installation that OctoPrint is installed under?

I get the same errors both via the manger and cli
plugin_pluginmanager_console (2).log (8.2 KB)

Did you get an answer to this? I have the same issue.

Can you try the same solution I put in this other post?


This worked! Thank you so much for taking the time to post the answer here. I did see your post when I was searching for the solution earlier.

Yes, the solution Charlie posted works for me.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.