I need help connecting to Makerbot

I am following these instructions: How to set up a printing server for your MakerBot Replicator 2. I'm not sure the mini is capable of Octoprint control. I have been using Octoprint for 2 years on the Anycubic Kossel.

What is the problem?
I can't get connected. AUTO doesn't work for connection settings.

What did you already try to solve it?
I ran dmesg and found the entry that recognizes the printer. I set the port to that dev (/dev/usb/lp0) and I get a p"permission denied" error, so I changed the dev permissions to 666 and now get "Inappropriate ioctl for device".

Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...)
dmesg:
[ 635.203393] usb 1-1.4: new high-speed USB device number 4 using dwc_otg
[ 636.813433] usb 1-1.4: device descriptor read/64, error -71
[ 637.064619] usb 1-1.4: New USB device found, idVendor=23c1, idProduct=0004
[ 637.064638] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 637.064649] usb 1-1.4: Product: MakerBot Replicator Mini
[ 637.064660] usb 1-1.4: Manufacturer: MakerBot Industries
[ 637.064670] usb 1-1.4: SerialNumber: 23C100043C705900BE28
[ 642.154030] usblp 1-1.4:1.0: usblp0: USB Bidirectional printer dev 4 if 0 alt 0 proto 2 vid 0x23C1 pid 0x0004
[ 642.154241] usbcore: registered new interface driver usblp

TERMINAL TAB:
Changing monitoring state from "Offline" to "Error: Connection error, see Terminal tab"
Unexpected error while connecting to serial port: /dev/usb/lp0 OSError: '[Errno 13] Permission denied: '/dev/usb/lp0'' @ comm.py:_openSerial:2611 (hook GPX)
Changing monitoring state from "Offline" to "Error: Connection error, see Terminal tab"
Unexpected error while connecting to serial port: /dev/usb/lp0 OSError: '[Errno 25] Inappropriate ioctl for device: '/dev/usb/lp0'' @ comm.py:_openSerial:2611 (hook GPX)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ...)
Octoprint v. 1.3.11
Octopi v. 0.16.0, running on Raspberry Pi 2 Model B Rev 1.1
Printer: Makerbot Replicator Mini

What is it with all these /dev/lp0 ports today here? :thinking:

/dev/lp0 is a parallel port device, not serial. OctoPrint won't work with it, not even with the GPX plugin. So it looks like you are out of luck with that printer.

That confirms my suspicion. Is there a way to force the OS to connect the printer to a serial device?

You could force the device name it appears under, but that still wouldn't change that it is a parallel interface, and probably a proprietary one to boot, so nothing that can be interfaced with.

The tutorial you indicated has this paragraph:

Instead of ‘AUTO’ settings, select /dev/ttyACM0 in the Serial Port dropdown (or whatever is there) and set Baudrate to 115200. (you might need to refresh your web page for the settings to appear)

Thanks, I've looked for ACM0, but it is not a valid dev.

Does anything at all appear in the dropdown? If not, then it's not the usual suspects that OctoPrint would try. Keep researching. Have you tried it as /dev/usblp0 by manually adding this in the Settings area? Do an ls -l /dev to see if this one is there.

The device that appears when the printer is connected is /dev/usb/lp0 and it is removed when the printer is turned off, so that is the proper printer device. Either the OS is detecting the device incorrectly as parallel, or the printer is parallel and it's not going to work with Octoprint.

1 Like

As foosel's suggested, that's probably not going to work at all then with this firmware (or hardware?)

Not sure what to tell you. Is it possible that there are more serial connectors on this printer and you've chosen the wrong one?

There is only one port - USB. I am moving on without Octoprint - sad. I'll probably attach an older computer to the printer and do desktop sharing (jumpdesktop) to control it remotely using the Makerbot Print app.

1 Like