I upgraded to 1.8.3 tons of problem

What is the problem?

I upgraded today to 1.8.3. After printing started camera not working. Obico plugin not working.
After 30 min printing, octoprint disconnected. After that point the restart, shutdown not working.
With 1.8.2 everything working fine.

What did you already try to solve it?

Disable resource monitor, but not solved my problem.

Have you tried running in safe mode?

Yes.

Did running in safe mode solve the problem?

Yes.

Systeminfo Bundle

octoprint-systeminfo-20220924214549.zip (230.7 KB)

Additional information about your setup

OctoPrint version: 1.8.3
OctoPi version: 0.18.0
Printer: TwoTrees SP-5 modded (SKR MINI E3 V2.0, TMC2209)
Firmware: Marlin 2.0.9.3
Browser: Chrome
Operating system: Windows 11 pro

Im having similar problems, updated to 1.8.3 and now octoprint disconnects sometimes in 1h sometimes after 7h. 15h print yesterday worked when i had my usb camera unplugged

1 Like

Hello @whpgab !

The one or more of the plugins is obviously the issue.

If you use UI customizer, you will not need Themeify.
It's recommended to turn the Resource Monitor off due to a unknown issue.

Also obico causes a lot of errors

Hello @siffonen !

Similar means not the same - which quite rare.

Please open a new thread in Get Help with all the information that are asked for in the template.

Resource monitor and Obico working with 1.8.2.
Is there a way to return back to 1.8.2?
Turning off all of my plug-ins is not an option for me.
What plug-in cause the disconnection?

"If you use UI customizer, you will not need Themeify."
There is something Themeify knows and UI customizer doesn't.

The issue with Resource Monitor is independent to the OctoPrint version:

Also Obico is not the recent version. (Regarding to the log)

To find that out, it has to be investigated by deactivate all 3rd party plugins and reactivate them one by one.

And that is?

I could not remember any blobs on my prints. But for safety and as I usually don't watch resource monitor, I turned it off.
Today I updated Obico, and now camera is working again.
Maybe Obico plug-in caused the disconnection. I have to print more to check it.

With Themeify I can easily set exact height of each panel, like "Files", etc.

1 Like

You can do this in UI Customizer with the Advanced Options...it's just done slightly different as you have to enter it in CSS formatting, like this.

<selector> {
  <CSS-Rule>: <value>;
}

It is even worse. Now I have 1.8.4. I have to turn off UI Customizer because octoprint didn't start up just in safe mode. The first loading proccess is a pain. I have to wait for the camera picture to start.

octoprint (11).log (1.2 MB)

Here is the log.

not really seeing any specific errors in that log that would indicate why you would be having a problem with UI Customizer and I've been using 1.8.4 since prior to its official release with that plugin enabled. check your browser's developer tools > console tab to see what errors are lurking in there during initial page load.