I3 Mini V2 Bed temp problem

The problem is the bed temperature is not staying constant. I can manually set the temp back to 60C and it will stay set. If octoprint sends a command to change or set the bed temp it all ways goes to 100c. I am new to this and looking for a little guidance. The printer is a PowerSpec Duplicator i3 Mini V2 3D Printer from Micro center.

octoprint.log (422.6 KB)logs.zip (1.8 MB)

Upload the serial.log please :slight_smile:
One thing I noticed in your octoprint.log is the amount of checksum errors. You should try a better cable :slight_smile:

1 Like

Thanks for taking a look. I did a test print with a new cable. The problem did not go away. I all so up loaded new log files from the test print.

I have never seen a behavior like this before.

2020-01-30 09:01:31,479 - Recv:  T:48.75 /210.00 B:19.96 /0.00 @:127 B@:0
2020-01-30 09:01:33,480 - Recv:  T:52.61 /210.00 B:19.92 /0.00 @:127 B@:0
2020-01-30 09:01:35,484 - Recv:  T:56.93 /210.00 B:19.96 /0.00 @:127 B@:0
2020-01-30 09:01:37,486 - Recv:  T:61.15 /210.00 B:19.88 /0.00 @:127 B@:0
2020-01-30 09:01:37,710 - Send: M140 S60
2020-01-30 09:01:37,721 - Recv: ok
2020-01-30 09:01:39,489 - Recv:  T:64.85 /210.00 B:19.96 /100.00 @:127 B@:127
2020-01-30 09:01:41,491 - Recv:  T:68.57 /210.00 B:20.31 /100.00 @:127 B@:127
2020-01-30 09:01:43,493 - Recv:  T:72.40 /210.00 B:21.37 /100.00 @:127 B@:127
2020-01-30 09:01:45,496 - Recv:  T:76.44 /210.00 B:22.58 /100.00 @:127 B@:127
2020-01-30 09:01:47,498 - Recv:  T:80.81 /210.00 B:24.53 /100.00 @:127 B@:127

What happens when you cange the temperature with M190 instead of M140 ?

And what happens if you set 40°C or 80°C instead of 60°C?

Why is it doing multiple M110's? Is that normal?

2020-01-29 20:31:06,596 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-01-29 20:31:06,599 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2020-01-29 20:31:07,849 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0

Tested setting temperature to 40 and 80c, and the bed temp changes to 100c. I noticed setting the bed temp when not printing works correctly, but once the print starts any temp setting changes will result in the printer going to 100c.

I tried using M190 S60 in the terminal and it did set correctly. Dose that mean I am using the wrong gcode?

I'm not sure what to do. I just bought the printer and have time to return it. I like it though and it seems to work well other then the bed temp problem. Thanks again for the help.

it's not wrong - it's just a different command.
M140 sets the temperature on the fly and with M190 the printer halts until the temperature is reached.
neither of both should change the temperature to 100°c (unless you set it to 100 of course).
I guess your firmware does something weird.
Use M190 if it works for you (just don't it mid print or the print or the printer will halt until the temperature is reached)

I'm not sure what happens when you set it to a lower temperature though. If I understand it correctly M190 S<lowertemperature> should behave like M140.
See here

I would flash a better firmware. Of course it sounds weird to mod a printer you just bought but that's something a lot of us do.
Many printers are delivered with messed up and very old firmware so we update them to a updated stock firmware without weird manufacturer modifications.
That also gives you the opportunity to change or add things like thermal runaway protection

1 Like

I agree updating the firmware is the best way to go. I am just not sure what the best or proper firmware is. Any suggestions would be great.

Before flashing a new firmware, you might want to first backup what you already have on there.

1 Like

First do the backup as @OutsourcedGuru suggested and then you might want to read a bit about marlin and how to compile and flash it.
I would try these configs

And here a video with some basics


I know this is bumping this older topic a bit, but were there any resolutions as to the steps taken for this? My print bed temperature is fine, though I am wondering about the Marlin upgrade and whether or not the OP was able to back up the firmware on the machine. I didn't really understand the steps necessary to make a backup using the suggested post.

Also were there any issues with setting up OctoPrint thereafter? I am interested in getting set up with a little Raspberry Pi with the heated printbed version 2 of this Duplicator i3 mini.

I had this issue before using octoprint and it took a lot of searching and headaches to figure out. The issue with the bed is that the power supply can't keep up, it can power the hot end and bed, but once the steppers activate the temp of the bed drops. If you take it apart you'll see that it's a weak power supply. It was just easier and cheaper to use a little bit of glue for long prints. If you want to spend the time and money, you can upgrade the power supply.

Leaving this here as a note for other people buying this printer from MicroCenter. I was able to backup the firmware and other settings as per the firmware post mentioned above.

These are the settings that worked for me wrapped into a script:

avrdude -c wiring -P /dev/ttyUSB0 -b 115200 -p m2560 -U flash:r:backup_flash.bin:r
avrdude -c wiring -P /dev/ttyUSB0 -b 115200 -p m2560 -U eeprom:r:eeprom_backup.hex
avrdude -c wiring -P /dev/ttyUSB0 -b 115200 -p m2560 -U hfuse:r:hfuse_backup.hex:r
avrdude -c wiring -P /dev/ttyUSB0 -b 115200 -p m2560 -U lfuse:r:lfuse_backup.hex:r
avrdude -c wiring -P /dev/ttyUSB0 -b 115200 -p m2560 -U efuse:r:efuse_backup.hex:r

Once finishing the firmware backup, I followed the instructions for compiling the Marlin firmware via the Arduino IDE and using the Duplicator i3 Mini configuration templates as a starting point. I changed a few aesthetic settings, but the one you'll also need to add is updating #define TEMP_SENSOR_BED 0 to #define TEMP_SENSOR_BED 75.

Compile and upload as the standard instructions suggest. Much nicer than the stock firmware! So far seems to play much nicer with OctoPrint too.

1 Like

FYI @ tehninini. Hope you've already figured it out though!