Iframe login loop issue

What is the problem?

Can't log into octoprint through home assistant, get the login loop.

What did you already try to solve it?

Google/forum search. Ticked the box. Tried running octoprint through a reserve proxy with https & http, no dice. Tried brave, chrome, firefox, edge.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20240107144650.zip (435.5 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Using latest octopi image. Tried multiple devices and networks.

So, did that work?

Nope, same issue on all of them, login loop.

How did you add the iframe stuff? I assume you've already enabled the option to allow embedding OctoPrint in an iframe in the settings?

I added a webpage panel to my HA instance and am seeing the same login loop. When looking at the response in developer tools I see this.

and on the actual login that's sending the username/password data this.

I've tried both by adding an iframe card to the dashboard, and the dashboard way iframe you've shown. And yes, the box is ticked.

So it's not just me then. That's good I guess. lol


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.