I'm sure it's simple but new installation of OctoPi doesn't work

What is the problem?

The OctoPrint service doesn't start on a new install.

The OctoPrint server is currently not running

If you just started up your Raspberry Pi, please wait a couple of seconds, then try to refresh this page.

If the issue persists, please log into your Raspberry Pi via SSH and check the following:

  • Verify that the process is running: ps -ef | grep -i octoprint | grep -i python should show a python process:

pi@octopi:~ $ ps -ef | grep -i octoprint | grep -i python
pi 1441 1 6 11:12 ? 00:00:15 /home/pi/oprint/bin/python
/home/pi/oprint/bin/octoprint --host= --port=5000

  • If it isn't, the question is why. Take a look into ~/.octoprint/logs/octoprint.log , there might be an error logged in there that helps to determine what's wrong.
  • You might also want to try if you can restart the server (if no obvious error is visible): sudo service octoprint restart .

If all that doesn't help to trouble shoot the issue, you can seek support on the OctoPrint Community Forum. Please provide your OctoPi and OctoPrint versions as well as your octoprint.log and explain what you already tried and observed as detailed as possible.

What did you already try to solve it?

I tried to look at the log, but the directory the log was supposed to be in didn't exist so I created it and rebooted, still no log to look at. Also tried running an update and got "There was an error running option 8 Update"

Have you tried running in safe mode?

Yes, it is like the command doesn't exist.

Did running in safe mode solve the problem?

I get the collowing when trying to run octoprint in safemode
pi@Octopi:~/.octoprint/logs $ octoprint safemode
-bash: octoprint: command not found

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

Running on a Pi 3 B, latest version, just extracted the image.


Are you able to run safe mode with GitHub - kantlivelong/OctoPi-SystemMenu: Simple TUI for common tasks on OctoPi ?

No, It says it the command isn't available.

From the safe mode link:

OctoPi users : For you thatโ€™s ~/oprint/bin/octoprint wherever it says just octoprint .

Try ~/oprint/bin/octoprint

I just re-imaged the SD card and it booted up fine. Very weird.

1 Like