I'm trying to update but it doesnt let me

What is the problem?
I currently have Octoprint version 1.3.12 and I'm trying to install the update for version 1.4 but with the update manager inside the service it results in an Error.
What did you already try to solve it?
I tried solving it by updating manually by doing the command inside the virtual environment with 'pip install -U octoprint' but it results in the samen error
Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

UI Error message:

ERROR: Command errored out with exit status 1: /home/santiago/share/Octoprint/env/bin/python2 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-EUFIia/psutil/setup.py'"'"'; __file__='"'"'/tmp/pip-install-EUFIia/psutil/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-ajmR0g/install-record.txt --single-version-externally-managed --compile --install-headers /home/santiago/share/Octoprint/env/include/site/python2.7/psutil 
Check the logs for full command output.


octoprint.plugins.softwareupdate - ERROR - Update of octoprint can not be performed, please also check plugin_softwareupdate_console.log for possible causes of this
Traceback (most recent call last):
  File "/home/santiago/share/Octoprint/env/lib/python2.7/site-packages/octoprint/plugins/softwareupdate/__init__.py", line 987, in _perform_update
    update_result = updater.perform_update(target, populated_check, target_version, log_cb=self._log, online=online)
  File "/home/santiago/share/Octoprint/env/lib/python2.7/site-packages/octoprint/plugins/softwareupdate/updaters/pip.py", line 116, in perform_update
    raise exceptions.UpdateError("Error while executing pip install", (stdout, stderr))

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

Im running octoprint in ubuntu server 18.04

Thank you for any information about how can i solve this

I was missing GCC a simple

apt-get install gcc

Solved it