Impossible to have PID

PID doesn't termine

What did you already try to solve it?

reetaing operation

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

Additional information about youoctoprint.log (105.1 KB)

r setup
browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.2 Safari/605.1.15
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 3959984128
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: true
octoprint.version: 1.7.3
systeminfo.generator: systemapi

octoprint.log (105.1 KB)

It seems, something is going on wrong with the heating.
It heats despite the target temperature is 0°C

2022-02-11 08:20:21,552 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: Heating failed, system stopped! Heater_ID: E0 -
| Last lines in terminal:
| Recv:  T:111.78 /0.00 @:127
| Recv:  T:111.94 /0.00 @:127
| Recv:  T:112.23 /0.00 @:127
| Recv:  T:112.47 /0.00 @:127
| Recv:  T:112.66 /0.00 @:127
| Recv:  T:112.86 /0.00 @:127
| Recv:  T:113.06 /0.00 @:127
| Recv:  T:113.23 /0.00 @:127
| Recv:  T:113.45 /0.00 @:127
| Recv:  T:113.62 /0.00 @:127
| Recv:  T:113.89 /0.00 @:127
| Recv:  T:114.02 /0.00 @:127
| Recv:  T:114.18 /0.00 @:127
| Recv:  T:114.40 /0.00 @:127
| Recv:  T:114.57 /0.00 @:127
| Recv:  T:114.72 /0.00 @:127
| Recv:  T:114.89 /0.00 @:127
| Recv:  T:115.07 /0.00 @:127
| Recv: Error:Heating failed, system stopped! Heater_ID: E0
| Recv


Hi, the file of the system.log is attached...

That is the octoprint.log, not the systeminfo bundle nor a system.log

So, I estimated your issue.

Actually, during PID autotune, there is no target temperature shown up - my fault

Can you share the PID autotune command you send to the printer?
I have the supposition that the hotend heats up too slow and the thermal runaway safety feature of the printer kicked in.

M303 C5 S200

This is the Command

Maybe the fan airflow is not regulated?
That because when I disconnect the cable the temperature grows...

I assume that this can be the issue.

this fan runs at maximum of power; how to try to reduce speed?

Is that the part cooling fan or the cold end cooler?

You also can put a silicone sock on the heater block. It keeps the heat inside and the block clean.

I'll try with socket!

1 Like

octoprint.log (184.4 KB)

I tryed PID without Hotend FAN inactive and it finally worked!
At this point where to put hands for the solution?

The coldend cooler is not meant to cool the hotend so much that it can't heat at all.
Is it the one that the printer came with?
What printer is it you use?

no, I changed it with one of Trianglelab, V6 copper plated on my Two Trees Plus

Can you show us a picture of your extruder showing both cooling fans and the ducting on the part cooling fan?

At the moment I can’t as the hotend/fan is dismantled waiting for new one.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.