In terminal no temperature update

#1

SOLVED

I have a BIGTREETECH SKR V1.3 board.
The board is loaded with Marlin 2.0 by SD card and rebooted.
When I connected Octoprint it gave an instant EEprom error and disconnected..
At the second push to connect the connection was established no eeprom error anymore.
I opened the Terminal but there is no update of the temperatures.
After a while Octoprint errors out.
You can connect again but after a while again error and disconnect.
Can it happen that due to the eeprom error octoprint locks the reading of the temperature?
It happened now to two boards in a row.

One board cant do M502 but no M500 anymore
One board can do M502 and M500
Uploaded other firmware M2.0
Ran in safe mode
Version 1.3.10

If I connect the server to a SKR V1.1 there are no EEprom errors and the tempdata is refreshed @ 2secs in the terminal.

It looked as if Octo messed up the EEprom on both boards.

Anyone known to this behavior?
link to screenshot of printscreen terminal and error.
https://1drv.ms/u/s!AnuMP-b55jicgdkzf3g966003UYzwQ

Thanks, Paco

#2

Problem solved.
BIGTREETECH V1.3 firmware from GITHUB is the culprit.
When used with a fresh Marlin 2.0 from GITHUB the temps are shown again.

Paco

1 Like
#3

Hi @PacoRaap!

Nice you solved it. :+1:
Could please mark your second post as Solution (the check box is to find directly below your post).
Thank you!