Incorrect time and filament useage reported by Octoprint

EDIT: the estimate discrepancies are extreme. Also, I've been using Octoprint for roughly 3 months now, completely issue free.

What is the problem?

Print time is way off. Filament usage is way off.
Piece #1: Actual print time: ~9 hours; Octoprint reported print time: ~4 minutes.
Piece #2: Actual print time: ~35 mins; Octoprint reported print time: >2 hours.

What did you already try to solve it?

Did ocoprint software update.
Updated my raspberry pi.

Have you tried running in safe mode?

Not yet.

Did running in safe mode solve the problem?

Haven't tried yet.
octoprint.log (248.8 KB)
plugin_pluginmanager_console.log (10.5 KB)
plugin_softwareupdate_console.log (113.8 KB)
serial.log (148 Bytes)

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
Latest ocotoprint. Latest Raspberry Pi OS 32bit. (41.9 KB)


the times / discrepancies you post look extreme, haven't seen that bad, but yes, OctoPrint does a rough estimate, not a precise calculation. I slice my prints with prusaSlicer and it does much better predictions.

In OctoPrint, there is a plugin for it, PrintTimeGenius Plugin.It learns from previous prints and gets more and more precise.

Extreme is not strong enough of a word I think. I use printtimegenius btw.

It's really strange because I've been using Octoprint for many months now, on a thinkpad and currently on a Raspberry Pi 4.

Thanks for the reply!