Increasing the timelapse stills resolution Ras Pi cam v2.1

What is the problem?

I want to increase the resolution of the stills within octolapse, out the box it is at a default the resolution of 640x480. It seems to be very capable in the camera specs but i cannot get it off 640x480 resolution.

What did you already try to solve it?

Ssh pi@
Pi@octopi:~ $ Sudo service webcam restart
Pi@octopi:~ $ sudo nano /boot/octopi.txt
#camera_raspi_options="-r1920x1080 -fps 30"
camera_raspi_options="-ev -4 -usestills -x 1920 -y 1080 —fps 30 -awb off --awbgainR 1.7 --awbgainB 1.5 -quality 90"
Ctrl x
Pi@octopi:~ $ sudo reboot

Have you tried running in safe mode and if so did it solve the issue?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

i have the octolapse log do i just paste it here? its long...

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Pi 4b 8gb, 4" hyperpixel, running octopi 17, octodash, octolapse, Pi cam v2.1.

i have made edits to octopi.txt and webcamd, i made the same edit both files and tried uncommenting camera "auto" in octopi.txt and changing to camera "raspi" when i do this i indeed get a livefeed in a browser window at the new resolution but an error in octolapse that it could not retrieve feed, when i type the http feed address into the browser its a live feed and ok.
when i comment out camera"raspi" with the # the feed drops back to 640x480 and no error in octolapse.
any ideas or help please guys?
Also when i change webcamd back to normal it doesnt effect either edits in octopi.txt

Screenshot 2020-09-26 at 22.45.50 Screenshot 2020-09-25 at 12.21.25 120236550_637832200210309_616728997009292057_n

A friend of mine has made the exact same edits code for code on a USB cam in the USB part of octopi.txt and webcamd and his is working as expected with a higher resolution ( i copied his code but in the raspi section and altered -r for -x -w)
Did i give the right log file?octoprint.log (1.7 MB)