Inline login doesn't work, normal login page works


#1

What is the problem?

When I go to my Octopi at http://octopi/ I am not logged in but I see the whole main page but with no data. So I click logon in the upper right corner and enter credentials and hit login. Nothing happens. I just get back to the main page, still logged out and no data. If I then hit refresh I get to the separate login page (the one that takes up the whole web page). I enter my credentials and bam, I'm logged in and everything is fine! :slight_smile:

What did you already try to solve it?

Search...
Cleared cookies and cache

Additional information about your setup

Octopi with Octoprint 1.3.10
Chrome 72.0.3626.121
Win10


#2

Can you share screenshots and perhaps logs?


#3

Absolutely! :slight_smile:

I go to my Octopi adress:

Then choose to login:

But after hitting login I'm still not logged in (even if I wait)

So I push refresh in the browser (F5) and this pops up

And I get logged in and all is well :slight_smile:

And log file from this session:

octoprint.log (8.2 KB)


#4

For me, it seems that your Chrome skips the Forced Login in the first place.
After F5 it appears.
You could disable that plugin and see if it's still the same way.


#5

Yeah, looks like caching. There are two hard problems in computer science: caching, naming, and off by one errors.


#6

Yeah, if I hit refresh immediately I get to the working login page immediately. If I never hit refresh I never can login hehe.


#7

Including @foosel because she'll be interested in this.


#8

Shouldn't I be automatically logged in if I have Remember Me checked?

Oh, BTW, I see this problem on Chrome on Android too.


#9

I got same problem. Any solution? Thx


#10

Really odd but now autologin works with chrome on Android...