Install problems "Orange Pi" models PC or Lite

OS: Armbian buster with Linux 5.4.35-sunxi

OctoPrint version: I cannot tell, because the "octoprint --version" command fails as below

Python 2.7

Trying to install OctoPrint on either a Orange Pi PC or Lite boards,

I cannot start the server nor get version info out of OctoPrint:

Error (see full output below):
pkg_resources.DistributionNotFound: The 'markdown<3.2,>=3.1' distribution was not found and is required by OctoPrint

What did you already try to solve it?
Tried to update to 'markdown 3.2' but apparently it doesn't exist, at least not for Python 2.7

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)
I'd give you the logs, but I cannot find them. There is no log file anywhere in the OctoPrint directory. There is no log in the /var/log directory called 'octoprint.log'. The 'locate' command cannot find octoprint.log either.

This command: "~/OctoPrint/venv/bin/octoprint serve"
Produces this output on the terminal window:
Traceback (most recent call last):
  File "/home/octopi/OctoPrint/venv/bin/octoprint", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/home/octopi/OctoPrint/venv/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3191, in <module>
    @_call_aside
  File "/home/octopi/OctoPrint/venv/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3175, in _call_aside
    f(*args, **kwargs)
  File "/home/octopi/OctoPrint/venv/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3204, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/home/octopi/OctoPrint/venv/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 583, in _build_master
    ws.require(__requires__)
  File "/home/octopi/OctoPrint/venv/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/home/octopi/OctoPrint/venv/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'markdown<3.2,>=3.1' distribution was not found and is required by OctoPrint

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)
As I said, I cannot get the OctoPrint version, because that command fails. I'm sure it in a text file someplace, tell me where to look and I'll provide it. No browser involved, as I cannot start the server.

Problem solved by rolling OctoPrint back to ver. 1.3.8. I have no idea what it would take to get the latest version working on the Orange Pi's that I have.

I've got a couple of Orange Pi Zero's, I found the software support very hit and miss, mostly miss, but I do have one in my shed running openWRT, as a hot spot, works a treat. One of those occasions maybe when an original Pi saves a lot of aggro!. Must get some more orange Pi's to play with though.

They certainly are cheap enough !! About $10.50 USD for a new Zero. I'm pretty sure the problem I'm having with the newer version of OctoPrint is not related to the Orange Pi, but to some sort of issue with the version of some needed package not being correct. The most common OS for the OPi is Debian-based, and there are lots of systems running Debian and OctoPrint w/o issue. Maybe an issue within the OPi, in the sense of an incorrect paskage.

Sometimes you need to run the update / upgrade twice. There are dependencies that will get installed the first go round. The second will succeed.

I've never had an issue with Armbian. I don't what this thread to discourage the use of Orange Pi's. They work perfectly, on Armbian, and with Octoprint.

No webcam issues either, good power supply / usb printer cable as always.

Thanks!

1 Like

the logs are not in "/var/log/" You need to understand the guide you followed and read more posts.

So, are you suggesting to run the update/upgrade twice in a row, or run the second one AFTER installing OctoPrint, but before trying to run it ??

TIA !!

Had the same issue, and reverting to 1.3.4 worked and i could update from the octoprint ui to 1.4.0

But having issues with the server part of this guide!

Can only make octoprint run with :
~/OctoPrint/venv/bin/octoprint serve

from point 22. in that guide nothing seems to work!

Noob here to Armbian.
Cheers!

I finally got it working on an Orange Pi Zero, but had to roll back to OctoPrint 1.3.8. I tried upgrading to 1.4, but it failed. So, for now, I'm just going to let this "sleeping dog" lay.

I've had mine a while, its probably just as much a software maturity thing as anything else. I need a LOT more Pi's to play with, mine are busy. So a visit to AliExpress is probably imminent..